summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/replicatorg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/replicatorg')
-rw-r--r--media-gfx/replicatorg/Manifest2
-rwxr-xr-xmedia-gfx/replicatorg/files/replicatorg2
-rw-r--r--media-gfx/replicatorg/metadata.xml13
-rw-r--r--media-gfx/replicatorg/replicatorg-37-r2.ebuild85
-rw-r--r--media-gfx/replicatorg/replicatorg-40-r1.ebuild85
5 files changed, 187 insertions, 0 deletions
diff --git a/media-gfx/replicatorg/Manifest b/media-gfx/replicatorg/Manifest
new file mode 100644
index 000000000000..676788de2f4b
--- /dev/null
+++ b/media-gfx/replicatorg/Manifest
@@ -0,0 +1,2 @@
+DIST replicatorg-0037-linux.tgz 52627038 SHA256 304d942cc47933953bd4a74e7c88d6137e5ad0a5c4d0a6d0c51fa703d279f4cd SHA512 9fabfe64a6ff6c059abe66404349739cd74bcc244a4f37d020d506fd82d318f5103daeb289f615fe47203c43ea8842487acbe21b6cdbb9cdb4d9b20bfbfd845c WHIRLPOOL 62fa5629366bb9d5b32537834e2fdabf5ab3514282e7c24aeec4c04f8513fb4367514117089b7d7075c12d79f32ec059d1ef59c0f62803e0dbf34d0dccd3cb20
+DIST replicatorg-0040-linux.tgz 45962287 SHA256 9f614c2f0ae4494c73af84fd07937115d3c739bea638acf226419b80d31d2aad SHA512 c2be8679ebcb722a01f46bbd5a3dd771ebda0eb5e5546627f9064b412be0e5ae0b63f9d44dc7f03d9b3fb862c45dbe09edfb15018a075f39ca57d725ca804205 WHIRLPOOL 2088a517b11938f430a100d6f4e41cd14c6cc7db6954c8ce3475e019cdd2e9cb8833632b841affb88445d5b5ad1f99d8d9d85cb03651020e261aa53b05737059
diff --git a/media-gfx/replicatorg/files/replicatorg b/media-gfx/replicatorg/files/replicatorg
new file mode 100755
index 000000000000..2c91bf254346
--- /dev/null
+++ b/media-gfx/replicatorg/files/replicatorg
@@ -0,0 +1,2 @@
+#!/bin/bash
+( cd /opt/replicatorg ; ./replicatorg )
diff --git a/media-gfx/replicatorg/metadata.xml b/media-gfx/replicatorg/metadata.xml
new file mode 100644
index 000000000000..b32219d4b98d
--- /dev/null
+++ b/media-gfx/replicatorg/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>mattm@gentoo.org</email>
+<name>Matthew Marlowe</name>
+</maintainer>
+<longdescription>
+This is the software that will drive your MakerBot Replicator, Thing-O-Matic, CupCake CNC, RepRap machine, or generic CNC machine. You can give it a GCode or STL file to process, and it takes it from there. It's cross platform, easily installed, and is based on the familiar Arduino / Processing environments. ReplicatorG is used by thousands of MakerBot Operators, and has printed tens of thousands of objects and counting.
+</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/media-gfx/replicatorg/replicatorg-37-r2.ebuild b/media-gfx/replicatorg/replicatorg-37-r2.ebuild
new file mode 100644
index 000000000000..72a35a87ce31
--- /dev/null
+++ b/media-gfx/replicatorg/replicatorg-37-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils versionator user
+
+MY_P="${PN}-00${PV}"
+
+DESCRIPTION="ReplicatorG is a simple, open source 3D printing program"
+HOMEPAGE="http://replicat.org/start"
+SRC_URI="http://replicatorg.googlecode.com/files/${MY_P}-linux.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+COMMON_DEPEND="dev-java/oracle-jre-bin"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup replicator
+}
+
+pkg_postinst() {
+ elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
+ elog
+ elog "Ensure that your user account has permissions to access serial port,"
+ elog "if you plan to connect directly to a 3d printer rather than using"
+ elog "a flash card. Printing directly from replicatorg is preferred."
+ elog
+ elog "The replicator printer will likely show up in /dev as ttyACM0."
+ elog "You may want to autoload the cdc_acm kernel module."
+ elog
+ elog "Note that replicatorg includes its own version of skeinforge."
+ elog "There doesn't seem to be a simple way to depend on an external"
+ elog "version."
+ elog
+ elog "Replicatorg users should add themselves to the replicator group"
+ elog "to avoid upstream warnings about not being able to modify shared"
+ elog "skeinforge scripts."
+ elog
+ chmod -R g+w "${ROOT}"/opt/replicatorg
+ chown -R root:replicator "${ROOT}"/opt/replicatorg
+ chmod 0755 /opt/replicatorg
+}
+
+src_install() {
+ dodir \
+ /opt/replicatorg \
+ /usr/share/replicatorg
+
+ keepdir \
+ /opt/replicatorg \
+ /usr/share/replicatorg
+
+ dobin "${FILESDIR}"/replicatorg
+
+ /bin/cp -R --preserve=mode \
+ docs \
+ examples \
+ lib \
+ lib-i686 \
+ lib-x86_64 \
+ machines \
+ scripts \
+ replicatorg \
+ skein_engines \
+ tools \
+ "${D}"/opt/replicatorg/
+
+ insinto /usr/share/replicatorg
+ doins -r \
+ contributors.txt \
+ license.txt \
+ readme.txt \
+ todo.txt
+
+}
diff --git a/media-gfx/replicatorg/replicatorg-40-r1.ebuild b/media-gfx/replicatorg/replicatorg-40-r1.ebuild
new file mode 100644
index 000000000000..fc5dede1caf0
--- /dev/null
+++ b/media-gfx/replicatorg/replicatorg-40-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils versionator user
+
+MY_P="${PN}-00${PV}"
+
+DESCRIPTION="ReplicatorG is a simple, open source 3D printing program"
+HOMEPAGE="http://replicat.org/start"
+SRC_URI="http://replicatorg.googlecode.com/files/${MY_P}-linux.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=""
+
+IUSE=""
+
+COMMON_DEPEND="dev-java/oracle-jre-bin"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup replicator
+}
+
+pkg_postinst() {
+ elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
+ elog
+ elog "Ensure that your user account has permissions to access serial port,"
+ elog "if you plan to connect directly to a 3d printer rather than using"
+ elog "a flash card. Printing directly from replicatorg is preferred."
+ elog
+ elog "The replicator printer will likely show up in /dev as ttyACM0."
+ elog "You may want to autoload the cdc_acm kernel module."
+ elog
+ elog "Note that replicatorg includes its own version of skeinforge."
+ elog "There doesn't seem to be a simple way to depend on an external"
+ elog "version."
+ elog
+ elog "Replicatorg users should add themselves to the replicator group"
+ elog "to avoid upstream warnings about not being able to modify shared"
+ elog "skeinforge scripts."
+ elog
+ chmod -R g+w "${ROOT}"/opt/replicatorg
+ chown -R root:replicator "${ROOT}"/opt/replicatorg
+ chmod 0755 /opt/replicatorg
+}
+
+src_install() {
+ dodir \
+ /opt/replicatorg \
+ /usr/share/replicatorg
+
+ keepdir \
+ /opt/replicatorg \
+ /usr/share/replicatorg
+
+ dobin "${FILESDIR}"/replicatorg
+
+ /bin/cp -R --preserve=mode \
+ docs \
+ examples \
+ lib \
+ lib-i686 \
+ lib-x86_64 \
+ machines \
+ scripts \
+ replicatorg \
+ skein_engines \
+ tools \
+ "${D}"/opt/replicatorg/
+
+ insinto /usr/share/replicatorg
+ doins -r \
+ contributors.txt \
+ license.txt \
+ readme.txt \
+ todo.txt
+
+}