summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-10 08:56:12 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-10 08:56:33 +0200
commit53bd2f7ea658aa2f6c20ebe854d2bd0c374608ed (patch)
tree9543b2f97f6dbc9c45cd6b4e9ae72917813f1eb0 /media-gfx/ristretto/ristretto-0.8.1.ebuild
parentdev-ruby/ruby_dep: add 1.5.0 (diff)
downloadgentoo-53bd2f7ea658aa2f6c20ebe854d2bd0c374608ed.tar.gz
gentoo-53bd2f7ea658aa2f6c20ebe854d2bd0c374608ed.tar.bz2
gentoo-53bd2f7ea658aa2f6c20ebe854d2bd0c374608ed.zip
media-gfx/ristretto: Bump to 0.8.1
Diffstat (limited to 'media-gfx/ristretto/ristretto-0.8.1.ebuild')
-rw-r--r--media-gfx/ristretto/ristretto-0.8.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/ristretto/ristretto-0.8.1.ebuild b/media-gfx/ristretto/ristretto-0.8.1.ebuild
new file mode 100644
index 000000000000..0e120dd0ea2f
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A fast and lightweight picture viewer for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/ristretto"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.98:0=
+ >=dev-libs/glib-2.24:2=
+ media-libs/libexif:0=
+ x11-libs/cairo:0=
+ >=x11-libs/gtk+-2.20:2=
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.10:0=
+ >=xfce-base/libxfce4util-4.10:0=
+ >=xfce-base/xfconf-4.10:0="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS TODO )
+}