summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLara Maia <dev@lara.click>2016-02-18 14:06:25 -0200
committerLara Maia <dev@lara.click>2016-02-20 20:38:16 -0200
commit2d7cc6fb2ac5f777b8213b1c59d01bb90826a616 (patch)
tree555052c92fd49776fe41ad7472fd13897b6c3bc3 /media-gfx/splash-themes-livedvd/splash-themes-livedvd-12.0-r2.ebuild
parentprofiles/package.mask: Remove nonmatching gkeys{,-gen} masks (diff)
downloadgentoo-2d7cc6fb2ac5f777b8213b1c59d01bb90826a616.tar.gz
gentoo-2d7cc6fb2ac5f777b8213b1c59d01bb90826a616.tar.bz2
gentoo-2d7cc6fb2ac5f777b8213b1c59d01bb90826a616.zip
media-gfx/splash-themes-livedvd: Use functions.sh from gentoo-functions
Update rc_init-pre to use new path for functions.sh https://bugs.gentoo.org/show_bug.cgi?id=504406
Diffstat (limited to 'media-gfx/splash-themes-livedvd/splash-themes-livedvd-12.0-r2.ebuild')
-rw-r--r--media-gfx/splash-themes-livedvd/splash-themes-livedvd-12.0-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/splash-themes-livedvd/splash-themes-livedvd-12.0-r2.ebuild b/media-gfx/splash-themes-livedvd/splash-themes-livedvd-12.0-r2.ebuild
new file mode 100644
index 000000000000..1c6c31a0552b
--- /dev/null
+++ b/media-gfx/splash-themes-livedvd/splash-themes-livedvd-12.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Gentoo theme for gensplash consoles"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~tampakrap/tarballs/${P}.tar.bz2"
+
+LICENSE="Artistic GPL-2 BitstreamVera"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+DEPEND=">=media-gfx/splashutils-1.4.1[png]"
+RDEPEND="${DEPEND}
+ sys-apps/gentoo-functions"
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
+}
+
+src_install() {
+ dodir /etc/splash/livedvd-${PV}
+ insinto /etc/splash/livedvd-${PV}
+ doins -r *
+ insopts -m 0755
+ doins -r scripts
+}