summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2021-01-22 13:36:34 -0800
committerSteve Arnold <nerdboy@gentoo.org>2021-01-22 13:37:27 -0800
commit68492f535ce82d95fe43ea7855234f77a704baee (patch)
treea2304eadc87f7f9c1d83c39d52142c4dd914ac21 /media-gfx/svg2rlg
parentpackage.mask: Extend glibc mask (diff)
downloadgentoo-68492f535ce82d95fe43ea7855234f77a704baee.tar.gz
gentoo-68492f535ce82d95fe43ea7855234f77a704baee.tar.bz2
gentoo-68492f535ce82d95fe43ea7855234f77a704baee.zip
media-gfx/svg2rlg: new (revived) ebuild, dep for rst2pdf
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'media-gfx/svg2rlg')
-rw-r--r--media-gfx/svg2rlg/Manifest1
-rw-r--r--media-gfx/svg2rlg/metadata.xml14
-rw-r--r--media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/svg2rlg/Manifest b/media-gfx/svg2rlg/Manifest
new file mode 100644
index 000000000000..90d6bb2a4348
--- /dev/null
+++ b/media-gfx/svg2rlg/Manifest
@@ -0,0 +1 @@
+DIST svg2rlg-0.4.0.tar.gz 504861 BLAKE2B bfd147d824d5a49f8621e705f6bdeefdaa571918db94afea8e839d048d2089a8c8ebf8e2763caa9866f55a7142e1bb3522b01f53eaf5b8343164a08ee0983ef3 SHA512 e3813a22784c2199a1df69574c64093347a153fa2b7a40e2f38f52e5d46d7ca8d6e8e3bbe54ab59381f6c7246352c016ff3e19b1278c6f2c8dcfbe8bd7017b12
diff --git a/media-gfx/svg2rlg/metadata.xml b/media-gfx/svg2rlg/metadata.xml
new file mode 100644
index 000000000000..6ca266787624
--- /dev/null
+++ b/media-gfx/svg2rlg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+ </maintainer>
+ <longdescription lang="en">
+ A tool to convert from SVG to reportlab graphics objects.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sarnold/svg2rlg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
new file mode 100644
index 000000000000..dd314bc752d8
--- /dev/null
+++ b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Converts SVG files to PDFs or reportlab graphics"
+HOMEPAGE="https://github.com/sarnold/svg2rlg https://pypi.python.org/pypi/svg2rlg/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/svg2rlg.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ nosetests -sx test_svg2rlg.py || die "Test failed with ${EPYTHON}"
+}