summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-16 01:26:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-16 01:46:17 +0200
commit12faa1f3969c1f632a6f939f46e4377c08c37fab (patch)
tree66a917f6b1aeb919ababa61fe45e4221ea025387 /media-gfx/ufraw
parentmedia-gfx/ufraw: Fix build with >=media-libs/exiv2-0.27.1 (diff)
downloadgentoo-12faa1f3969c1f632a6f939f46e4377c08c37fab.tar.gz
gentoo-12faa1f3969c1f632a6f939f46e4377c08c37fab.tar.bz2
gentoo-12faa1f3969c1f632a6f939f46e4377c08c37fab.zip
media-gfx/ufraw: Fix build with gcc-9, EAPI-7 bump
Thanks to openSUSE for the patch. Closes: https://bugs.gentoo.org/685138 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/ufraw')
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-gcc9.patch97
-rw-r--r--media-gfx/ufraw/ufraw-0.22-r3.ebuild96
2 files changed, 193 insertions, 0 deletions
diff --git a/media-gfx/ufraw/files/ufraw-0.22-gcc9.patch b/media-gfx/ufraw/files/ufraw-0.22-gcc9.patch
new file mode 100644
index 000000000000..f2cf1dc88a86
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.22-gcc9.patch
@@ -0,0 +1,97 @@
+From ac8c74699cba65d65f918b3f4cba2de64e039ada Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=A9rgio=20M=2E=20Basto?= <sergio@serjux.com>
+Date: Thu, 14 Feb 2019 03:26:02 +0000
+Subject: [PATCH] Fix GCC 9 OpenMP issues by drop default(none)
+
+---
+ dcraw_api.cc | 4 ++--
+ dcraw_indi.c | 4 ----
+ ufraw_ufraw.c | 6 +++---
+ 3 files changed, 5 insertions(+), 9 deletions(-)
+
+diff --git a/dcraw_api.cc b/dcraw_api.cc
+index c3d2902..6096cb7 100644
+--- a/dcraw_api.cc
++++ b/dcraw_api.cc
+@@ -686,7 +686,7 @@ extern "C" {
+ rgbWB[3] = rgbWB[1];
+ if (dark) {
+ #ifdef _OPENMP
+- #pragma omp parallel for schedule(static) default(none) \
++ #pragma omp parallel for schedule(static) \
+ shared(h,dark,rgbWB)
+ #endif
+ for (int i = 0; i < pixels; i++) {
+@@ -699,7 +699,7 @@ extern "C" {
+ }
+ } else {
+ #ifdef _OPENMP
+- #pragma omp parallel for schedule(static) default(none) \
++ #pragma omp parallel for schedule(static) \
+ shared(h,dark,rgbWB)
+ #endif
+ for (int i = 0; i < pixels; i++) {
+diff --git a/dcraw_indi.c b/dcraw_indi.c
+index a291af2..777ce39 100644
+--- a/dcraw_indi.c
++++ b/dcraw_indi.c
+@@ -137,12 +137,10 @@ void CLASS wavelet_denoise_INDI(ushort(*image)[4], const int black,
+ #ifdef _OPENMP
+ #if defined(__sun) && !defined(__GNUC__) /* Fix bug #3205673 - NKBJ */
+ #pragma omp parallel for \
+- default(none) \
+ shared(nc,image,size,noise) \
+ private(c,i,hpass,lev,lpass,row,col,thold,fimg,temp)
+ #else
+ #pragma omp parallel for \
+- default(none) \
+ shared(nc,image,size) \
+ private(c,i,hpass,lev,lpass,row,col,thold,fimg,temp)
+ #endif
+@@ -413,7 +411,6 @@ void CLASS vng_interpolate_INDI(ushort(*image)[4], const unsigned filters,
+ progress(PROGRESS_INTERPOLATE, -height);
+ #ifdef _OPENMP
+ #pragma omp parallel \
+- default(none) \
+ shared(image,code,prow,pcol,h) \
+ private(row,col,g,brow,rowtmp,pix,ip,gval,diff,gmin,gmax,thold,sum,color,num,c,t)
+ #endif
+@@ -496,7 +493,6 @@ void CLASS ppg_interpolate_INDI(ushort(*image)[4], const unsigned filters,
+
+ #ifdef _OPENMP
+ #pragma omp parallel \
+- default(none) \
+ shared(image,dir,diff) \
+ private(row,col,i,d,c,pix,guess)
+ #endif
+diff --git a/ufraw_ufraw.c b/ufraw_ufraw.c
+index ce9d262..48a0d91 100644
+--- a/ufraw_ufraw.c
++++ b/ufraw_ufraw.c
+@@ -1043,7 +1043,7 @@ static void ufraw_shave_hotpixels(ufraw_data *uf, dcraw_image_type *img,
+ delta = rgbMax / (uf->conf->hotpixel + 1.0);
+ count = 0;
+ #ifdef _OPENMP
+- #pragma omp parallel for schedule(static) default(none) \
++ #pragma omp parallel for schedule(static) \
+ shared(uf,img,width,height,colors,rgbMax,delta) \
+ reduction(+:count) \
+ private(h,p,w,c,t,v,hi,i)
+@@ -1365,7 +1365,7 @@ static void ufraw_convert_reverse_wb(ufraw_data *uf, UFRawPhase phase)
+ mul[i] = (guint64)0x10000 * 0x10000 / uf->developer->rgbWB[i];
+ size = img->height * img->width;
+ #ifdef _OPENMP
+- #pragma omp parallel for schedule(static) default(none) \
++ #pragma omp parallel for schedule(static) \
+ shared(uf,phase,img,mul,size) \
+ private(i,p16,c,px)
+ #endif
+@@ -1390,7 +1390,7 @@ static void ufraw_convert_image_tca(ufraw_data *uf, ufraw_image_data *img,
+ return;
+ int y;
+ #ifdef _OPENMP
+- #pragma omp parallel for schedule(static) default(none) \
++ #pragma omp parallel for schedule(static) \
+ shared(uf,img,outimg,area)
+ #endif
+ for (y = area->y; y < area->y + area->height; y++) {
diff --git a/media-gfx/ufraw/ufraw-0.22-r3.ebuild b/media-gfx/ufraw/ufraw-0.22-r3.ebuild
new file mode 100644
index 000000000000..b43d97d6022b
--- /dev/null
+++ b/media-gfx/ufraw/ufraw-0.22-r3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools gnome2-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="RAW Image format viewer and GIMP plugin"
+HOMEPAGE="http://ufraw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="contrast fits gimp gnome gtk openmp timezone"
+
+REQUIRED_USE="gimp? ( gtk )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/exiv2:=
+ media-libs/lcms:2=
+ >=media-libs/lensfun-0.2.5:=
+ media-libs/libpng:0=
+ media-libs/tiff
+ virtual/jpeg:0=
+ fits? ( sci-libs/cfitsio:= )
+ gimp? ( >=media-gfx/gimp-2 )
+ gnome? ( >=gnome-base/gconf-2 )
+ gtk? (
+ >=media-gfx/gtkimageview-1.5
+ >=x11-libs/gtk+-2.6:2
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.17-cfitsio-automagic.patch
+ "${FILESDIR}"/${P}-jasper-automagic.patch
+ "${FILESDIR}"/${P}-crashfix.patch
+ "${FILESDIR}"/${P}-drop_superfluous_abs.patch
+ "${FILESDIR}"/${P}-fix-unsigned-char.patch
+ "${FILESDIR}"/${P}-jpeg9.patch
+ "${FILESDIR}"/${P}-exiv2-0.27.patch
+ "${FILESDIR}"/${P}-gcc9.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-jasper
+ $(use_enable contrast)
+ $(use_with fits cfitsio)
+ $(use_with gimp)
+ $(use_enable gnome mime)
+ $(use_with gtk)
+ $(use_enable openmp)
+ $(use_enable timezone dst-correction)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" schemasdir=/etc/gconf/schemas install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if use gnome; then
+ gnome2_gconf_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gnome; then
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+ gnome2_gconf_install
+ fi
+}
+
+pkg_postrm() {
+ if use gnome; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}