summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/wings
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/wings')
-rw-r--r--media-gfx/wings/Manifest1
-rw-r--r--media-gfx/wings/files/wings.sh4
-rw-r--r--media-gfx/wings/metadata.xml18
-rw-r--r--media-gfx/wings/wings-1.1.1.ebuild45
4 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/wings/Manifest b/media-gfx/wings/Manifest
new file mode 100644
index 000000000000..c07c9dba831c
--- /dev/null
+++ b/media-gfx/wings/Manifest
@@ -0,0 +1 @@
+DIST wings-1.1.1.tar.bz2 1932572 SHA256 1a75a39a1a4586b242558a879d611adf1566b86785750f48ba60d851c2e40d08
diff --git a/media-gfx/wings/files/wings.sh b/media-gfx/wings/files/wings.sh
new file mode 100644
index 000000000000..e542588910a6
--- /dev/null
+++ b/media-gfx/wings/files/wings.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+ESDL_ROOT="/usr/lib/erlang/lib/esdl"
+WINGS_ROOT="/usr/lib/erlang/lib/wings"
+exec erl -smp disable -noshell -pa $ESDL_ROOT/ebin $WINGS_ROOT/ebin -run wings_start start_halt
diff --git a/media-gfx/wings/metadata.xml b/media-gfx/wings/metadata.xml
new file mode 100644
index 000000000000..1faadf36651d
--- /dev/null
+++ b/media-gfx/wings/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <longdescription>
+Wings 3D is a polygon mesh modeler inspired by Nendo and
+Mirai from Izware.
+
+It is possible to assign materials, vertex color, UV
+coordinates and textures, but there will be improvements
+in those features before Wings goes 1.0.
+
+There is no support in Wings for doing animations.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">wings</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/wings/wings-1.1.1.ebuild b/media-gfx/wings/wings-1.1.1.ebuild
new file mode 100644
index 000000000000..2e0636af6fbc
--- /dev/null
+++ b/media-gfx/wings/wings-1.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit multilib eutils
+
+DESCRIPTION="excellent 3D polygon mesh modeler"
+HOMEPAGE="http://www.wings3d.com/"
+SRC_URI="mirror://sourceforge/wings/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/erlang-13.0
+ >=media-libs/esdl-1.0.1
+ media-libs/libsdl[opengl]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ ERL_PATH="/usr/$(get_libdir)/erlang/lib/"
+ ESDL_PATH="${ERL_PATH}/$(best_version media-libs/esdl | cut -d/ -f2)"
+}
+
+src_compile() {
+ make ESDL_PATH="${ERL_PATH}/$(best_version media-libs/esdl | cut -d/ -f2)" || die
+}
+
+src_install() {
+ WINGS_PATH=${ERL_PATH}/${P}
+ dodir ${WINGS_PATH}
+
+ find -name 'Makefile*' -exec rm -f '{}' \;
+ for subdir in e3d ebin icons plugins plugins_src src fonts ; do
+ cp -r ${subdir} "${D}"/${WINGS_PATH}/ || die
+ done
+
+ dosym ${WINGS_PATH} ${ERL_PATH}/${PN}
+ dosym ${ESDL_PATH} ${ERL_PATH}/esdl
+ newbin "${FILESDIR}"/wings.sh wings
+ dodoc AUTHORS README
+}