summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-02-17 14:28:13 +0100
committerUlrich Müller <ulm@gentoo.org>2020-02-17 16:53:58 +0100
commit9f359924f7b78bf0bd15a69380ff41a7c005fa5e (patch)
tree080e5541fef732e956c9d6204bd60b537cd3a1f5 /media-gfx/word_cloud/word_cloud-1.6.0.ebuild
parentdev-db/mysql: ppc64 stable wrt bug #709624 (diff)
downloadgentoo-9f359924f7b78bf0bd15a69380ff41a7c005fa5e.tar.gz
gentoo-9f359924f7b78bf0bd15a69380ff41a7c005fa5e.tar.bz2
gentoo-9f359924f7b78bf0bd15a69380ff41a7c005fa5e.zip
media-gfx/word_cloud: Initial import.
Ebuild contributed by me. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'media-gfx/word_cloud/word_cloud-1.6.0.ebuild')
-rw-r--r--media-gfx/word_cloud/word_cloud-1.6.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/word_cloud-1.6.0.ebuild b/media-gfx/word_cloud/word_cloud-1.6.0.ebuild
new file mode 100644
index 000000000000..a8a60e0fb337
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=( "${FILESDIR}"/${P}-bundled-font.patch )