summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-02 09:38:42 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-10 10:22:34 +0300
commitc76540d35e33b244bb00d4a36a226d7afefb05f8 (patch)
tree4653ebd3f2f10d79761e8a04164701f751395fdc /media-gfx/xfig
parentdev-python/nuitka: bump version to 0.6.9.1 (diff)
downloadgentoo-c76540d35e33b244bb00d4a36a226d7afefb05f8.tar.gz
gentoo-c76540d35e33b244bb00d4a36a226d7afefb05f8.tar.bz2
gentoo-c76540d35e33b244bb00d4a36a226d7afefb05f8.zip
media-gfx/xfig: bump to 3.2.7b
Bug: https://bugs.gentoo.org/718806 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/17744 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/xfig')
-rw-r--r--media-gfx/xfig/Manifest1
-rw-r--r--media-gfx/xfig/xfig-3.2.7b.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-gfx/xfig/Manifest b/media-gfx/xfig/Manifest
index 106af3f0e1e3..f8d167641cd5 100644
--- a/media-gfx/xfig/Manifest
+++ b/media-gfx/xfig/Manifest
@@ -1 +1,2 @@
+DIST xfig-3.2.7b.tar.xz 5059984 BLAKE2B a22465e16019e9887e302ea308e250ad5d7ba0c49aec8f554a73d3b4489d803a05041cb7d267c543a7c0d3b78eac25077c628283f82767932afcc9d9750ce883 SHA512 f3396ebf8a5961909e58b05b60117fd7bbc8c24fabbd47f108eaea9586f4180af572faffe077b1a5dcbf669ebd69b1c2791f302c126dea62a44aa1592de66f73
DIST xfig-full-3.2.6a.tar.xz 5502944 BLAKE2B 3a83feeb5647ffa9586b9ce40116e9854a423c0cc90265ad78b27c0c82a15bbda9d9734475aba13f442c259cd0489a667242f319ac758ddbfea1a5b268e12550 SHA512 82e292e050213b6d22be5e174224308b446505e25208f29d4f4c5e760a87ff4104b9dcea0a332241c9bca358e1d44336bb38c316eb3f28130d7c8828c10a805f
diff --git a/media-gfx/xfig/xfig-3.2.7b.ebuild b/media-gfx/xfig/xfig-3.2.7b.ebuild
new file mode 100644
index 000000000000..f7c2b6a8e8c7
--- /dev/null
+++ b/media-gfx/xfig/xfig-3.2.7b.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="A menu-driven tool to draw and manipulate objects interactively in an X window"
+HOMEPAGE="http://mcj.sourceforge.net/"
+SRC_URI="https://kumisystems.dl.sourceforge.net/project/mcj/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="jpeg nls postscript"
+
+RDEPEND="
+ x11-libs/libXaw
+ x11-libs/libXaw3d
+ x11-libs/libXi
+ x11-libs/libXt
+ media-libs/libpng:0=
+ media-fonts/font-misc-misc
+ media-fonts/urw-fonts
+ >=media-gfx/transfig-3.2.5-r1
+ media-libs/netpbm
+ jpeg? ( virtual/jpeg:0= )
+ nls? ( x11-libs/libXaw3d[unicode] )
+ postscript? ( app-text/ghostscript-gpl )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.6a-urwfonts.patch"
+ "${FILESDIR}/${PN}-3.2.6a-solaris.patch"
+ "${FILESDIR}/${PN}-3.2.6a-app-defaults.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls i18n)
+ $(use_enable jpeg)
+ $(use_with postscript gs)
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}" # it expects docdir...
+ )
+ econf "${myeconfargs[@]}"
+}