summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 02:19:38 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:37:03 -0400
commit4da9499919dba27b2009fe6517e1fa7e40aa631c (patch)
tree3ad806c9588b1bc80fed8b21079938637d1d3f69 /media-gfx/xli
parentmedia-gfx/transfig: force gcc -E for imake's generation (diff)
downloadgentoo-4da9499919dba27b2009fe6517e1fa7e40aa631c.tar.gz
gentoo-4da9499919dba27b2009fe6517e1fa7e40aa631c.tar.bz2
gentoo-4da9499919dba27b2009fe6517e1fa7e40aa631c.zip
media-gfx/xli: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Bug: https://bugs.gentoo.org/870790 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/xli')
-rw-r--r--media-gfx/xli/xli-1.17.0-r5.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-gfx/xli/xli-1.17.0-r5.ebuild b/media-gfx/xli/xli-1.17.0-r5.ebuild
index a62e12b505df..35ea8f0999eb 100644
--- a/media-gfx/xli/xli-1.17.0-r5.ebuild
+++ b/media-gfx/xli/xli-1.17.0-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
app-text/rman
+ sys-devel/gcc
x11-base/xorg-proto
>=x11-misc/imake-1.0.8-r1"
@@ -57,7 +58,7 @@ src_prepare() {
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {