summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-22 15:51:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-22 16:50:34 +0200
commit115ef47d90a31b86423d33845023b58fff05ca1e (patch)
treeb5cc17a7e09a05e05fdebd9c483c7ec19283b946 /media-gfx
parentdev-util/cmake: Bump to version 3.15.0_rc2 (diff)
downloadgentoo-115ef47d90a31b86423d33845023b58fff05ca1e.tar.gz
gentoo-115ef47d90a31b86423d33845023b58fff05ca1e.tar.bz2
gentoo-115ef47d90a31b86423d33845023b58fff05ca1e.zip
media-gfx/kxstitch: Drop 2.1.1-r2
Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/kxstitch/Manifest1
-rw-r--r--media-gfx/kxstitch/files/kxstitch-2.1.1-imagemagick-fix.patch99
-rw-r--r--media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch37
-rw-r--r--media-gfx/kxstitch/kxstitch-2.1.1-r2.ebuild46
4 files changed, 0 insertions, 183 deletions
diff --git a/media-gfx/kxstitch/Manifest b/media-gfx/kxstitch/Manifest
index 269543effbcb..756774fdacc0 100644
--- a/media-gfx/kxstitch/Manifest
+++ b/media-gfx/kxstitch/Manifest
@@ -1,2 +1 @@
-DIST kxstitch-2.1.1.tar.xz 1726364 BLAKE2B 47257408f31ca7db4bddf984150baac6cd850206cedb95c73b0d62ee9f966028afd97bb3653b385104a1c679512c35f41aa25c5b703c715e565d48cfda59da36 SHA512 d5a6b6d06bfb894dd7404cb81350389f1ebf5c8a463eb792358abd67f362d1e1f578d06319461a006625864f1c4a69ebb4ccd0db422870c3eae0516c9132a3b3
DIST kxstitch-2.2.0.tar.xz 1784360 BLAKE2B 6d06090bb33ccd4db7e8b8a3521b0e1377f253b472cc500862b1b8b0da1abf0d759a85a870b50a1a1f55f385274cdc94761e612a838d93aaffb76191df725150 SHA512 bf09130a35bc605db2bbd6e5e129ac494e8f02b920d4a8d6705b5030a9339306b3b302bd988839e1684da3e5e15e91d655dadf916eb4bf2dc9c1322fd435281d
diff --git a/media-gfx/kxstitch/files/kxstitch-2.1.1-imagemagick-fix.patch b/media-gfx/kxstitch/files/kxstitch-2.1.1-imagemagick-fix.patch
deleted file mode 100644
index bf8c5e14096b..000000000000
--- a/media-gfx/kxstitch/files/kxstitch-2.1.1-imagemagick-fix.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From 75a129d3c2f21914a47b970df822e485aca625ac Mon Sep 17 00:00:00 2001
-From: Steve Allewell <steve.allewell@gmail.com>
-Date: Sun, 11 Nov 2018 15:48:50 +0000
-Subject: Fix for importing images for V6 of ImageMagick
-
-The getPixelColor in V6 of ImageMagick does not appear to return the
-same information as in V7, consequently importing images has resulted in
-a black image when using V6 of ImageMagick. This fix reverts the change
-made in commit 295773f44bfda1227d85edf065a8de14dc889159 when using V6.
-
-Big thanks to Sean Enck for reporting and helping diagnose the problem.
----
- src/ImportImageDlg.cpp | 16 ++++++++++++++++
- src/MainWindow.cpp | 17 +++++++++++++++++
- 2 files changed, 33 insertions(+)
-
-diff --git a/src/ImportImageDlg.cpp b/src/ImportImageDlg.cpp
-index e6396c6..340ff1d 100644
---- a/src/ImportImageDlg.cpp
-+++ b/src/ImportImageDlg.cpp
-@@ -391,9 +391,21 @@ void ImportImageDlg::renderPixmap()
- QProgressDialog progress(i18n("Rendering preview"), i18n("Cancel"), 0, pixelCount, this);
- progress.setWindowModality(Qt::WindowModal);
-
-+/*
-+ * ImageMagick prior to V7 used matte (opacity) to determine if an image has transparency.
-+ * 0.0 for transparent to 1.0 for opaque
-+ *
-+ * ImageMagick V7 now uses alpha (transparency).
-+ * 1.0 for transparent to 0.0 for opaque
-+ *
-+ * Access to pixels has changed too, V7 can use pixelColor to access the color of a particular
-+ * pixel, but although this was available in V6, it doesn't appear to produce the same result
-+ * and has resulted in black images when importing.
-+ */
- #if MagickLibVersion < 0x700
- bool hasTransparency = m_convertedImage.matte();
- double transparent = 1.0;
-+ const Magick::PixelPacket *pixels = m_convertedImage.getConstPixels(0, 0, width, height);
- #else
- bool hasTransparency = m_convertedImage.alpha();
- double transparent = 0.0;
-@@ -408,7 +420,11 @@ void ImportImageDlg::renderPixmap()
- }
-
- for (int dx = 0 ; dx < width ; dx++) {
-+#if MagickLibVersion < 0x700
-+ Magick::ColorRGB rgb = Magick::Color(*pixels++);
-+#else
- Magick::ColorRGB rgb = m_convertedImage.pixelColor(dx, dy);
-+#endif
-
- if (hasTransparency && (rgb.alpha() == transparent)) {
- //ignore this pixel as it is transparent
-diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index 1f12f5b..ecf552a 100644
---- a/src/MainWindow.cpp
-+++ b/src/MainWindow.cpp
-@@ -541,13 +541,26 @@ void MainWindow::convertImage(const QString &source)
-
- bool useFractionals = importImageDlg->useFractionals();
-
-+/*
-+ * ImageMagick prior to V7 used matte (opacity) to determine if an image has transparency.
-+ * 0.0 for transparent to 1.0 for opaque
-+ *
-+ * ImageMagick V7 now uses alpha (transparency).
-+ * 1.0 for transparent to 0.0 for opaque
-+ *
-+ * Access to pixels has changed too, V7 can use pixelColor to access the color of a particular
-+ * pixel, but although this was available in V6, it doesn't appear to produce the same result
-+ * and has resulted in black images when importing.
-+ */
- #if MagickLibVersion < 0x700
- bool hasTransparency = convertedImage.matte();
- double transparent = 1.0;
-+ const Magick::PixelPacket *pixels = convertedImage.getConstPixels(0, 0, imageWidth, imageHeight);
- #else
- bool hasTransparency = convertedImage.alpha();
- double transparent = 0.0;
- #endif
-+
- bool ignoreColor = importImageDlg->ignoreColor();
- Magick::Color ignoreColorValue = importImageDlg->ignoreColorValue();
-
-@@ -579,7 +592,11 @@ void MainWindow::convertImage(const QString &source)
- }
-
- for (int dx = 0 ; dx < imageWidth ; dx++) {
-+#if MagickLibVersion < 0x700
-+ Magick::ColorRGB rgb = Magick::Color(*pixels++); // is this a memory leak
-+#else
- Magick::ColorRGB rgb = convertedImage.pixelColor(dx, dy);
-+#endif
-
- if (hasTransparency && (rgb.alpha() == transparent)) {
- // ignore this pixel as it is transparent
---
-cgit v1.1
diff --git a/media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch b/media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch
deleted file mode 100644
index 70022fe9c8fa..000000000000
--- a/media-gfx/kxstitch/files/kxstitch-2.1.1-qt-5.11.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 9db3fcf9cd367681c0864238dc5009a604f3896c Mon Sep 17 00:00:00 2001
-From: Jonathan Riddell <jr@jriddell.org>
-Date: Wed, 27 Jun 2018 16:45:16 +0100
-Subject: fix build with Qt 5.11
-
----
- src/LibraryPatternPropertiesDlg.cpp | 2 ++
- src/TextElementDlg.cpp | 1 +
- 2 files changed, 3 insertions(+)
-
-diff --git a/src/LibraryPatternPropertiesDlg.cpp b/src/LibraryPatternPropertiesDlg.cpp
-index 8d2e24c..c10da3f 100644
---- a/src/LibraryPatternPropertiesDlg.cpp
-+++ b/src/LibraryPatternPropertiesDlg.cpp
-@@ -11,6 +11,8 @@
-
- #include "LibraryPatternPropertiesDlg.h"
-
-+#include <QIcon>
-+
- #include <KConfigGroup>
- #include <KHelpClient>
- #include <KLocalizedString>
-diff --git a/src/TextElementDlg.cpp b/src/TextElementDlg.cpp
-index 4d88b1e..fb545d1 100644
---- a/src/TextElementDlg.cpp
-+++ b/src/TextElementDlg.cpp
-@@ -16,6 +16,7 @@
- #include "TextElementDlg.h"
-
- #include <QColorDialog>
-+#include <QButtonGroup>
-
- #include <KHelpClient>
- #include <KLocalizedString>
---
-cgit v0.11.2
diff --git a/media-gfx/kxstitch/kxstitch-2.1.1-r2.ebuild b/media-gfx/kxstitch/kxstitch-2.1.1-r2.ebuild
deleted file mode 100644
index 232c67d1a141..000000000000
--- a/media-gfx/kxstitch/kxstitch-2.1.1-r2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-KDE_HANDBOOK="forceoptional"
-inherit kde5
-
-DESCRIPTION="Program to create cross stitch patterns"
-HOMEPAGE="https://userbase.kde.org/KXStitch"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="~amd64"
-IUSE=""
-
-BDEPEND="
- sys-devel/gettext
-"
-DEPEND="
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep ktextwidgets)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtprintsupport)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- $(add_qt_dep qtxml)
- media-gfx/imagemagick[cxx]
- x11-libs/libX11
-"
-RDEPEND="${DEPEND}
- !media-gfx/kxstitch:4
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-qt-5.11.patch"
- "${FILESDIR}/${P}-imagemagick-fix.patch"
-)