summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Davila <davila.luis.us@gmail.com>2021-12-10 17:20:57 -0800
committerSam James <sam@gentoo.org>2021-12-11 01:29:12 +0000
commit192e9b063f056d9f66d8e348d52a4d76b77538c7 (patch)
tree715080fc4d85900f9416a67892731ce925dcbcdc /media-gfx
parentapp-emulation/libvirt: needs older Wireshark (diff)
downloadgentoo-192e9b063f056d9f66d8e348d52a4d76b77538c7.tar.gz
gentoo-192e9b063f056d9f66d8e348d52a4d76b77538c7.tar.bz2
gentoo-192e9b063f056d9f66d8e348d52a4d76b77538c7.zip
media-gfx/scrot: add 1.7
Closes: https://github.com/gentoo/gentoo/pull/23247 Signed-off-by: Luis Davila <davila.luis.us@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/scrot/Manifest1
-rw-r--r--media-gfx/scrot/files/scrot-1.7.bash-completion48
-rw-r--r--media-gfx/scrot/scrot-1.7.ebuild47
3 files changed, 96 insertions, 0 deletions
diff --git a/media-gfx/scrot/Manifest b/media-gfx/scrot/Manifest
index 49ab0ed27cd4..7354016426cb 100644
--- a/media-gfx/scrot/Manifest
+++ b/media-gfx/scrot/Manifest
@@ -1 +1,2 @@
DIST scrot-1.4.tar.gz 157779 BLAKE2B ba844f8bc500c468d028ce62ae57bd6a9fa0e403df6f05dd217722a9115456b70a38aabd7ccb0da53d855b9971d0f5948f82545ca0c8cceb75ede0d4546e27c1 SHA512 8423e7b2658f3e0ccf30f61e122016469226328adf8b1e511aeb031dd2655ae66582651e2d046c7c35d23efb98656369a02b59e711980481ddc4db24c299ee11
+DIST scrot-1.7.tar.gz 178463 BLAKE2B 021c68c5ebd19ec08c072cff73fe1ebb7ffd179dfcde6e13656779e2ee1357cf0fdbba1d4beb2fc5dc9c8c4cd28008acaa462068eec3192cea6687ac58cd653a SHA512 3ef2b547d561a85213ef0075af3034020f00168253d3b84ef94578f0b8534f9a7389c808f8fcd0c619358a14f41601fee407d08d63c397b9892ba9fc2db23f88
diff --git a/media-gfx/scrot/files/scrot-1.7.bash-completion b/media-gfx/scrot/files/scrot-1.7.bash-completion
new file mode 100644
index 000000000000..06bc7ac7fad3
--- /dev/null
+++ b/media-gfx/scrot/files/scrot-1.7.bash-completion
@@ -0,0 +1,48 @@
+# bash-completion script for scrot
+# place this in /etc/bash_completion.d
+
+_scrot() {
+ local cur prev opts
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+ opts="
+ -h --help -v --version -a --autoselect -b --border -c --count -d
+ --delay -e --exec -q --quality -m --multidisp -s --select -u --focused
+ -t --thumb -z --silent -p --pointer -f --freeze -o --overwrite -l --line
+ -n --note -C --class -i --ignorekeyboard -F --file -shole --select=hole
+ -shide --select=hide -sblur --select=blur
+ "
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]]; then
+ COMPREPLY=($(compgen -W "${opts}" -- "${cur}"))
+ fi
+
+ case "${prev}" in
+ -h|--help) COMPREPLY=($(compgen -W "${opts/-h --help}" -- "${cur}")) ;;
+ -v|--version) COMPREPLY=($(compgen -W "${opts/-v --version}" -- "${cur}")) ;;
+ -a|--autoselect) COMPREPLY=($(compgen -W "${opts/-a --autoselect}" -- "${cur}")) ;;
+ -b|--border) COMPREPLY=($(compgen -W "${opts/-b --border}" -- "${cur}")) ;;
+ -c|--count) COMPREPLY=($(compgen -W "${opts/-c --count}" -- "${cur}")) ;;
+ -d|--delay) COMPREPLY=($(compgen -W "${opts/-d --delay}" -- "${cur}")) ;;
+ -e|--exec) COMPREPLY=($(compgen -A command -- "${cur}")) ;;
+ -q|--quality) COMPREPLY=($(compgen -W "${opts/-q --quality}" -- "${cur}")) ;;
+ -m|--multidisp) COMPREPLY=($(compgen -W "${opts/-m --multidisp}" -- "${cur}")) ;;
+ -s|--select) COMPREPLY=($(compgen -W "${opts/-s --select}" -- "${cur}")) ;;
+ -u|--focused) COMPREPLY=($(compgen -W "${opts/-u --focused}" -- "${cur}")) ;;
+ -t|--thumb) COMPREPLY=($(compgen -W "${opts/-t --thumb}" -- "${cur}")) ;;
+ -z|--silent) COMPREPLY=($(compgen -W "${opts/-z --silent}" -- "${cur}")) ;;
+ -p|--pointer) COMPREPLY=($(compgen -W "${opts/-p --pointer}" -- "${cur}")) ;;
+ -f|--freeze) COMPREPLY=($(compgen -W "${opts/-f --freeze}" -- "${cur}")) ;;
+ -o|--overwrite) COMPREPLY=($(compgen -W "${opts/-o --overwrite}" -- "${cur}")) ;;
+ -l|--line) COMPREPLY=($(compgen -W "${opts/-l --line}" -- "${cur}")) ;;
+ -n|--note) COMPREPLY=($(compgen -W "${opts/-n --note}" -- "${cur}")) ;;
+ -C|--class)COMPREPLY=($(compgen -W "${opts/-C --class}" -- "${cur}")) ;;
+ -i|--ignorekeyboard)COMPREPLY=($(compgen -W "${opts/-i --ignorekeyboard}" -- "${cur}")) ;;
+ -F|--file)COMPREPLY=($(compgen -W "${opts/-F --file}" -- "${cur}")) ;;
+ -shole|--select=hole)COMPREPLY=($(compgen -W "${opts/-shole --select=hole}" -- "${cur}")) ;;
+ -shide|--select=hide)COMPREPLY=($(compgen -W "${opts/-shide --select=hide}" -- "${cur}")) ;;
+ -sblur|--select=blur)COMPREPLY=($(compgen -W "${opts/-sblur --select=blur}" -- "${cur}")) ;;
+ esac
+}
+complete -F _scrot scrot
diff --git a/media-gfx/scrot/scrot-1.7.ebuild b/media-gfx/scrot/scrot-1.7.ebuild
new file mode 100644
index 000000000000..9cad9ff4eae9
--- /dev/null
+++ b/media-gfx/scrot/scrot-1.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
+SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libbsd
+ >=media-libs/giblib-1.2.3
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ || (
+ media-libs/imlib2[gif]
+ media-libs/imlib2[jpeg]
+ media-libs/imlib2[png]
+ media-libs/imlib2[tiff]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog README.md
+)
+
+src_install() {
+ default
+
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
+}