summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 00:04:14 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:12:36 -0400
commit27a9c862e6fc42c99b114542421b5896043167cd (patch)
tree0723c9c8b14160a833281799a13becdfe008e645 /media-gfx
parentapp-arch/engrampa: 1.12.x vbump, add gtk3 support, import from project repo (diff)
downloadgentoo-27a9c862e6fc42c99b114542421b5896043167cd.tar.gz
gentoo-27a9c862e6fc42c99b114542421b5896043167cd.tar.bz2
gentoo-27a9c862e6fc42c99b114542421b5896043167cd.zip
media-gfx/eom: 1.12.x vbump, add gtk3 support, import from project repo
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eom/Manifest1
-rw-r--r--media-gfx/eom/eom-1.12.2-r2.ebuild82
-rw-r--r--media-gfx/eom/metadata.xml3
3 files changed, 86 insertions, 0 deletions
diff --git a/media-gfx/eom/Manifest b/media-gfx/eom/Manifest
index bdc0126cb374..4f064fb52250 100644
--- a/media-gfx/eom/Manifest
+++ b/media-gfx/eom/Manifest
@@ -1 +1,2 @@
DIST eom-1.10.5.tar.xz 2207424 SHA256 19b484dba1c2adf1450153815e4edb05ba7ab7bdf4eb8b4f2071766e48e72d14 SHA512 f58f2c4c1d211afe66c2a112b75ee6b325590294da51df3a56d1dca0fb813cea1abd9e9dc7a4a3f26c111f1c11aba20e8177e36913f04bae664f4ddad6f98c0c WHIRLPOOL 1ce95839628e51060f2c77e8a701046754817870f998a6388aa620e12470b2e690e11edd5e7770303da33103f0077a3726eba01bd537a2cc3729bbd29dbc92d0
+DIST eom-1.12.2.tar.xz 2213260 SHA256 38ad10a6794e02e9e319a293393a36532e86572010442ba2f1d3773313c0a1da SHA512 03283cb1cae817c7c21219913fe2f3ab64e0fa6662a63193d4fa012bd0b5c286cbd25131a5bd5e52c1d9304b4b10ae8c37d38a88ea985215c5b277303d7b8cc4 WHIRLPOOL ad1745e5a0b223b96f715488b36c9c96a6b0f439a5ace02f06c2e05d09c6260bbf29c6d103fb40adfbbe6140d5a981f954185b04d0065b90b5f71625eec7783c
diff --git a/media-gfx/eom/eom-1.12.2-r2.ebuild b/media-gfx/eom/eom-1.12.2-r2.ebuild
new file mode 100644
index 000000000000..af12c2f7bc4d
--- /dev/null
+++ b/media-gfx/eom/eom-1.12.2-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE image viewer"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X debug dbus exif gtk3 +introspection jpeg lcms python svg tiff xmp"
+
+REQUIRED_USE="
+ gtk3? ( !python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ "
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2:2
+ gnome-base/dconf:0
+ >=mate-base/mate-desktop-1.9.1[gtk3(-)=]
+ sys-libs/zlib:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2[introspection?,jpeg?,tiff?]
+ x11-libs/libX11:0
+ >=x11-misc/shared-mime-info-0.20:0
+ virtual/libintl:0
+ dbus? ( >=dev-libs/dbus-glib-0.71:0 )
+ exif? (
+ >=media-libs/libexif-0.6.14:0
+ virtual/jpeg:0
+ )
+ !gtk3? ( >=x11-libs/gtk+-2.18:2[introspection?] )
+ gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}]
+ )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( >=media-libs/exempi-1.99.5:2 )
+ !!media-gfx/mate-image-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_with X x) \
+ $(use_with dbus) \
+ $(use_with exif libexif) \
+ $(use_with jpeg libjpeg) \
+ $(use_with lcms cms) \
+ $(use_with svg librsvg) \
+ $(use_with xmp)
+}
diff --git a/media-gfx/eom/metadata.xml b/media-gfx/eom/metadata.xml
index 519571d6611b..1309b0168085 100644
--- a/media-gfx/eom/metadata.xml
+++ b/media-gfx/eom/metadata.xml
@@ -5,6 +5,9 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/eom</remote-id>
</upstream>