summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-12 16:59:58 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-12 17:03:45 +0200
commit2e4000e9e113d8280850e999de6d2dbcff184075 (patch)
tree235d36883c880a485b3541975c3ecea3bb9c7a50 /media-gfx
parentdev-lang/lua: remove all except the latest slotted versions (diff)
downloadgentoo-2e4000e9e113d8280850e999de6d2dbcff184075.tar.gz
gentoo-2e4000e9e113d8280850e999de6d2dbcff184075.tar.bz2
gentoo-2e4000e9e113d8280850e999de6d2dbcff184075.zip
media-gfx/darktable: migrate to lua-single.eclass
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/darktable/darktable-3.2.1-r1.ebuild12
-rw-r--r--media-gfx/darktable/metadata.xml1
2 files changed, 9 insertions, 4 deletions
diff --git a/media-gfx/darktable/darktable-3.2.1-r1.ebuild b/media-gfx/darktable/darktable-3.2.1-r1.ebuild
index adbe95a27f15..8c8b42321646 100644
--- a/media-gfx/darktable/darktable-3.2.1-r1.ebuild
+++ b/media-gfx/darktable/darktable-3.2.1-r1.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit cmake flag-o-matic toolchain-funcs xdg
+LUA_COMPAT=( lua5-3 )
+
+inherit cmake flag-o-matic lua-single toolchain-funcs xdg
DOC_PV="3.0.0"
MY_PV="${PV/_/}"
@@ -19,9 +21,11 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64"
LANGS=" de es fr he it pl pt-BR ru sl"
IUSE="colord cups cpu_flags_x86_sse3 doc flickr geolocation gnome-keyring gphoto2 graphicsmagick jpeg2k kwallet
- lto lua nls opencl openmp openexr tools webp
+ lto lua nls opencl openmp openexr system-lua tools webp
${LANGS// / l10n_}"
+REQUIRED_USE="system-lua? ( lua ${LUA_REQUIRED_USE} )"
+
BDEPEND="
dev-util/intltool
virtual/pkgconfig
@@ -55,6 +59,7 @@ COMMON_DEPEND="
jpeg2k? ( media-libs/openjpeg:2= )
opencl? ( virtual/opencl )
openexr? ( media-libs/openexr:0= )
+ system-lua? ( ${LUA_DEPS} )
webp? ( media-libs/libwebp:0= )
"
DEPEND="${COMMON_DEPEND}
@@ -98,13 +103,12 @@ src_prepare() {
}
src_configure() {
- # TODO: switch to system Lua once 5.3 has been unmasked
local mycmakeargs=(
- -DDONT_USE_INTERNAL_LUA=OFF
-DBUILD_CURVE_TOOLS=$(usex tools)
-DBUILD_NOISE_TOOLS=$(usex tools)
-DBUILD_PRINT=$(usex cups)
-DCUSTOM_CFLAGS=ON
+ -DDONT_USE_INTERNAL_LUA=$(usex system-lua)
-DRAWSPEED_ENABLE_LTO=$(usex lto)
-DUSE_CAMERA_SUPPORT=$(usex gphoto2)
-DUSE_COLORD=$(usex colord)
diff --git a/media-gfx/darktable/metadata.xml b/media-gfx/darktable/metadata.xml
index 63e4e905d37f..bc5ef3457885 100644
--- a/media-gfx/darktable/metadata.xml
+++ b/media-gfx/darktable/metadata.xml
@@ -15,6 +15,7 @@
<flag name="kwallet">Enable encrypted storage of passwords with <pkg>kde-frameworks/kwallet</pkg></flag>
<flag name="lto">Enable link-time optimisations in the RawSpeed library</flag>
<flag name="opencl">Enable opencl support</flag>
+ <flag name="system-lua">Use dev-lang/lua instead of the bundled liblua</flag>
<flag name="tools">Install tools for generating base curves and noise profiles</flag>
</use>
<upstream>