summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-04-15 21:37:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-04-15 21:37:32 +0100
commit439d46108718e32e9c8f8528391184bf9155062e (patch)
tree2826d5eaa95fb565361a9a65b484c159b3997292 /media-gfx
parentdev-perl/Perl-Tags: Soft-disable tests since they mess up the terminal badly (diff)
downloadgentoo-439d46108718e32e9c8f8528391184bf9155062e.tar.gz
gentoo-439d46108718e32e9c8f8528391184bf9155062e.tar.bz2
gentoo-439d46108718e32e9c8f8528391184bf9155062e.zip
media-gfx/tif22pnm: add missing -lm, bug #516274
Reported-by: Patrick Lauer Bug: https://bugs.gentoo.org/516274 Package-Manager: portage-2.2.28
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch31
-rw-r--r--media-gfx/tif22pnm/tif22pnm-0.14.ebuild3
2 files changed, 33 insertions, 1 deletions
diff --git a/media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch b/media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch
new file mode 100644
index 000000000000..99c6dba3aac6
--- /dev/null
+++ b/media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/516274
+diff --git a/cc_help.sh.in b/cc_help.sh.in
+index b20feb6..1820304 100644
+--- a/cc_help.sh.in
++++ b/cc_help.sh.in
+@@ -7,2 +7,3 @@ LIBS_PNG='@LIBS_PNG@'
+ LIBS_TIFF='@LIBS_TIFF@'
++LIBS_MATH='@LIBS_MATH@'
+ ENABLE_DEBUG='@ENABLE_DEBUG@'
+diff --git a/configure.in b/configure.in
+index d11f42c..459ad8f 100644
+--- a/configure.in
++++ b/configure.in
+@@ -125,2 +125,8 @@ fi
+
++LIBS=""
++AC_SEARCH_LIBS([pow], [m], [LIBS_MATH="$LIBS"], [
++ AC_MSG_ERROR([unable to find the pow() function])
++])
++AC_SUBST(LIBS_MATH)
++
+ dnl Checks for header files.
+diff --git a/do.sh b/do.sh
+index fa15db8..0e9f449 100755
+--- a/do.sh
++++ b/do.sh
+@@ -117,3 +117,3 @@ SOURCES='png22pnm.c'
+ TARGET=png22pnm
+-LIBS="$LIBS_PNG"
++LIBS="$LIBS_PNG $LIBS_MATH"
+ build
diff --git a/media-gfx/tif22pnm/tif22pnm-0.14.ebuild b/media-gfx/tif22pnm/tif22pnm-0.14.ebuild
index 2b78a6f059f9..e01fcc15430c 100644
--- a/media-gfx/tif22pnm/tif22pnm-0.14.ebuild
+++ b/media-gfx/tif22pnm/tif22pnm-0.14.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=4
-inherit autotools eutils
+inherit autotools eutils flag-o-matic
DESCRIPTION="tif22pnm and png22pnm command-line converters"
HOMEPAGE="http://pts.szit.bme.hu/ https://code.google.com/p/sam2p/"
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-math.patch
eautoreconf
}