summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-06-03 11:15:35 +0300
committerMichał Górny <mgorny@gentoo.org>2021-06-05 14:36:15 +0200
commit46ae38a7e0e44aef269a444bab234ee200e6f080 (patch)
tree3bde95ffb652998253853868826491ff26d785dd /media-gfx
parentprofiles/arch/arm64: drop obsolete mask for www-client/chromium[tcmalloc] (diff)
downloadgentoo-46ae38a7e0e44aef269a444bab234ee200e6f080.tar.gz
gentoo-46ae38a7e0e44aef269a444bab234ee200e6f080.tar.bz2
gentoo-46ae38a7e0e44aef269a444bab234ee200e6f080.zip
media-gfx/hydrus: Update to 442 + upnpc fix
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Closes: https://github.com/gentoo/gentoo/pull/21100 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hydrus/Manifest1
-rw-r--r--media-gfx/hydrus/files/test-exitcode.patch36
-rw-r--r--media-gfx/hydrus/files/upnpc.patch40
-rw-r--r--media-gfx/hydrus/hydrus-441-r1.ebuild (renamed from media-gfx/hydrus/hydrus-441.ebuild)68
-rw-r--r--media-gfx/hydrus/hydrus-442.ebuild136
5 files changed, 237 insertions, 44 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index 0265c837b479..667917701aec 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -1 +1,2 @@
DIST hydrus-441.tar.gz 38807432 BLAKE2B e8294a8eb4d808792f2ff50ad4776f078ba1003962b065883ec22fd68f46dc250b2bccf47005731fcc964b75e07977aed45023da1c7e4513fcfcc29d1b4d1a97 SHA512 81eeb59006644b9b33c33c8da3e003640116488509ce2e1426d2a5c0161adf208e31a45c2a5efc2902769bf91e3db56aabc6384f77e8354e0e113bcc6df3a131
+DIST hydrus-442.tar.gz 38818985 BLAKE2B 955f5d9969bd46184fbf5fb11b1bc17257d184acd34a9533a20bc35e20ff5cabcc3715ebbb39f42b926b8b00f570c7f483eed3b11472c78f82b9ceeafc3dc765 SHA512 5a78338426127b276b067b52f590e275e132ea2676a4933162183e183a015556351e13e55271240059a145627d8a2ce1f6fe1a07ef267580604e998328c5c4f6
diff --git a/media-gfx/hydrus/files/test-exitcode.patch b/media-gfx/hydrus/files/test-exitcode.patch
new file mode 100644
index 000000000000..d61d341ee1ef
--- /dev/null
+++ b/media-gfx/hydrus/files/test-exitcode.patch
@@ -0,0 +1,36 @@
+diff --git a/hydrus/hydrus_test.py b/hydrus/hydrus_test.py
+index 3504c9c..7f95af8 100644
+--- a/hydrus/hydrus_test.py
++++ b/hydrus/hydrus_test.py
+@@ -91,6 +91,9 @@ def boot():
+ if sys.stdin.isatty():
+
+ input( 'Press any key to exit.' )
++ else:
+
++ success = 0 if controller.was_successful else 1
++ sys.exit(success)
+
+
+diff --git a/hydrus/test/TestController.py b/hydrus/test/TestController.py
+index 0c43440..7e6c5ef 100644
+--- a/hydrus/test/TestController.py
++++ b/hydrus/test/TestController.py
+@@ -168,7 +168,6 @@ only_run = None
+ class Controller( object ):
+
+ def __init__( self, win, only_run ):
+-
+ self.app = win
+ self.win = win
+ self.only_run = only_run
+@@ -827,8 +826,7 @@ class Controller( object ):
+ def do_it():
+
+ try:
+-
+- runner.run( suite )
++ self.was_successful = runner.run( suite ).wasSuccessful()
+
+ finally:
+
diff --git a/media-gfx/hydrus/files/upnpc.patch b/media-gfx/hydrus/files/upnpc.patch
new file mode 100644
index 000000000000..ea78f2b70b63
--- /dev/null
+++ b/media-gfx/hydrus/files/upnpc.patch
@@ -0,0 +1,40 @@
+diff --git a/hydrus/core/networking/HydrusNATPunch.py b/hydrus/core/networking/HydrusNATPunch.py
+index c959753..6792d89 100644
+--- a/hydrus/core/networking/HydrusNATPunch.py
++++ b/hydrus/core/networking/HydrusNATPunch.py
+@@ -3,6 +3,7 @@ import socket
+ import subprocess
+ import threading
+ import traceback
++import shutil
+
+ from hydrus.core import HydrusConstants as HC
+ from hydrus.core import HydrusData
+@@ -18,7 +19,7 @@ if HC.PLATFORM_WINDOWS:
+
+ else:
+
+- possible_bin_filenames = [ 'upnpc-static', 'upnpc-shared', 'miniupnpc' ]
++ possible_bin_filenames = [ 'upnpc', 'upnpc-static', 'upnpc-shared', 'miniupnpc' ]
+
+ if HC.PLATFORM_LINUX:
+
+@@ -42,7 +43,17 @@ for filename in possible_bin_filenames:
+
+ UPNPC_PATH = possible_path
+
+-
++ break
++
++ maybe_in_path = shutil.which( filename )
++
++ if maybe_in_path:
++
++ UPNPC_PATH = maybe_in_path
++
++ break
++
++
+ EXTERNAL_IP = {}
+ EXTERNAL_IP[ 'ip' ] = None
+ EXTERNAL_IP[ 'time' ] = 0
diff --git a/media-gfx/hydrus/hydrus-441.ebuild b/media-gfx/hydrus/hydrus-441-r1.ebuild
index 2e6f4152ae78..5ce5c4bdf642 100644
--- a/media-gfx/hydrus/hydrus-441.ebuild
+++ b/media-gfx/hydrus/hydrus-441-r1.ebuild
@@ -9,7 +9,7 @@ PYTHON_REQ_USE="sqlite"
inherit python-single-r1 desktop optfeature
DESCRIPTION="A booru-like media organizer for the desktop"
-HOMEPAGE="http://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
# hydrus itself is WTFPL
@@ -39,7 +39,7 @@ RDEPEND="
dev-python/service_identity[${PYTHON_MULTI_USEDEP}]
dev-python/six[${PYTHON_MULTI_USEDEP}]
dev-python/twisted[${PYTHON_MULTI_USEDEP}]
- media-libs/opencv[python,${PYTHON_MULTI_USEDEP}]
+ media-libs/opencv[python,png,jpeg,${PYTHON_MULTI_USEDEP}]
>=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_MULTI_USEDEP}]
dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
@@ -48,12 +48,12 @@ RDEPEND="
ffmpeg? ( media-video/ffmpeg )
lz4? ( dev-python/lz4[${PYTHON_MULTI_USEDEP}] )
mpv? (
- media-video/mpv[libmpv,${PYTHON_MULTI_USEDEP}]
- dev-python/python-mpv[${PYTHON_MULTI_USEDEP}]
+ media-video/mpv[libmpv,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpv[${PYTHON_MULTI_USEDEP}]
)
socks? (
- || ( dev-python/requests[socks5,${PYTHON_MULTI_USEDEP}]
- dev-python/PySocks[${PYTHON_MULTI_USEDEP}] )
+ || ( dev-python/requests[socks5,${PYTHON_MULTI_USEDEP}]
+ dev-python/PySocks[${PYTHON_MULTI_USEDEP}] )
)
')
"
@@ -70,26 +70,14 @@ BDEPEND="
"
PATCHES=(
+ "${FILESDIR}/upnpc.patch"
"${FILESDIR}/userpath-in-local-share.patch"
+ "${FILESDIR}/test-exitcode.patch"
)
-# Delete files only needed for testing
-delete_test_files() {
- rm test.py || die
- rm hydrus/hydrus_test.py || die
- rm -r hydrus/test/ || die
- rm -r static/testing/ || die
-}
-
src_prepare() {
default
- # If tests will run, leave the files until tests are run.
- # They will be deleted before installing the package.
- if ! use test; then
- delete_test_files
- fi
-
# Contains pre-built binaries for other systems and a broken swf renderer for linux
rm -r bin/ || die
# Build files used for CI, not actually needed
@@ -107,47 +95,39 @@ src_compile() {
src_test() {
# The tests use unittest, but are run with a custom runner script.
# QT_QPA_PLATFORM is required to make them run without X
- export QT_QPA_PLATFORM=offscreen
+ local -x QT_QPA_PLATFORM=offscreen
"${EPYTHON}" "${S}/test.py" || die "Tests failed"
}
src_install() {
- local DOC="${EPREFIX}/usr/share/doc/${PF}"
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
elog "Hydrus includes an excellent manual, that can either be viewed at"
- elog "${DOC}/html/help/index.html"
+ elog "${doc}/html/help/index.html"
elog "or accessed through the hydrus help menu."
mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
- DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
- HTML_DOCS=("${S}"/help/)
+ local DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
+ local HTML_DOCS=("${S}"/help/)
einstalldocs
- if use test; then
- # Delete files only needed for tests now. No need to install them.
- # If the tests didn't run, the files have been deleted already.
- delete_test_files
- fi
+ # Files only needed for testing
+ rm test.py hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ static/testing/ || die
- # These files are copied into DOC
- rm COPYING README.md Readme.txt help_my_client_will_not_boot.txt || die
- rm -r help/ db/ || die
- # The program expects to find documentation here, so add a symlink to DOC
- ln -s "${DOC}/html/help" help || die
+ # These files are copied into doc
+ rm -r "${DOCS[@]}" "${HTML_DOCS[@]}" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ ln -s "${doc}/html/help" help || die
- insopts -m0755
insinto /opt/hydrus
- doins -r "${S}"/*
+ doins -r "${S}"/.
exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server")
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client")
- sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" > "${T}/hydrus-server" || die
- sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" > "${T}/hydrus-client" || die
-
- python_doexe "${T}/hydrus-server"
- python_doexe "${T}/hydrus-client"
-
- make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png"\
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
"AudioVideo;FileTools;Graphics;Network;"
}
diff --git a/media-gfx/hydrus/hydrus-442.ebuild b/media-gfx/hydrus/hydrus-442.ebuild
new file mode 100644
index 000000000000..5ce5c4bdf642
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-442.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 desktop optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+mpv +ffmpeg +lz4 socks +cloudscraper charts test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/psutil[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyside2[widgets,gui,charts?,${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ dev-python/service_identity[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ dev-python/twisted[${PYTHON_MULTI_USEDEP}]
+ media-libs/opencv[python,png,jpeg,${PYTHON_MULTI_USEDEP}]
+
+ >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+
+ cloudscraper? ( dev-python/cloudscraper[${PYTHON_MULTI_USEDEP}] )
+ ffmpeg? ( media-video/ffmpeg )
+ lz4? ( dev-python/lz4[${PYTHON_MULTI_USEDEP}] )
+ mpv? (
+ media-video/mpv[libmpv,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpv[${PYTHON_MULTI_USEDEP}]
+ )
+ socks? (
+ || ( dev-python/requests[socks5,${PYTHON_MULTI_USEDEP}]
+ dev-python/PySocks[${PYTHON_MULTI_USEDEP}] )
+ )
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ dev-python/unittest2[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/upnpc.patch"
+ "${FILESDIR}/userpath-in-local-share.patch"
+ "${FILESDIR}/test-exitcode.patch"
+)
+
+src_prepare() {
+ default
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Build files used for CI, not actually needed
+ rm -r static/build_files || die
+ # Duplicate license file, not needed
+ rm license.txt || die
+ # Python requirements files, not needed
+ rm requirements_*.txt || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ local -x QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+}
+
+src_install() {
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${doc}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ local DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
+ local HTML_DOCS=("${S}"/help/)
+ einstalldocs
+
+ # Files only needed for testing
+ rm test.py hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ static/testing/ || die
+
+ # These files are copied into doc
+ rm -r "${DOCS[@]}" "${HTML_DOCS[@]}" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ ln -s "${doc}/html/help" help || die
+
+ insinto /opt/hydrus
+ doins -r "${S}"/.
+
+ exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server")
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client")
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "support for automatic port forwarding" "net-libs/miniupnpc"
+}