summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-01-05 09:51:31 -0600
committerBen Kohler <bkohler@gentoo.org>2023-01-05 10:34:30 -0600
commit61bf407bc93db1f578346f0c6e3192f9365e7519 (patch)
treecd164803d44a96e18724e74c3a1e764e5105e57b /media-gfx
parentapp-editors/gnome-latex: Version bump to 3.44.0 (diff)
downloadgentoo-61bf407bc93db1f578346f0c6e3192f9365e7519.tar.gz
gentoo-61bf407bc93db1f578346f0c6e3192f9365e7519.tar.bz2
gentoo-61bf407bc93db1f578346f0c6e3192f9365e7519.zip
media-gfx/fotoxx: add 23.0
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-23.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index 851d7ef0daea..39f6ca6d70ff 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -1,3 +1,4 @@
DIST fotoxx-22.20.tar.gz 8687337 BLAKE2B 013a1f154ea9971c5ff5c33f3ab62bcec9a364f0d47a65648b251966a0b798e00dd80ced399bcfb3657cf2e95534d1e694dc2d2c36066502ddc3b50a645cdba0 SHA512 c9b6cb298546ab121be6ef2c907ce51e4a4060a52829ed1ef51475ae1e542c7cb39037402381969519907a2a66bd8f741452786ff3a25f30fbbd22b24032a436
DIST fotoxx-22.35.tar.gz 8675173 BLAKE2B 0d0c709da603a59f432b184b0477cc3a65166c39209c5ccd440cbb317d1c835cf9b2a64870b10bff07debc4617585ed976f8a2157ee1a600861c2edab9ad023f SHA512 aceec8172da1c2c40c422ac194ab870a39cc33d6e1f484fc5fd7292145636ef546fa400023bbcc403d7e2ad108eef6d1c696cce7983c39088fede3a8538801c4
DIST fotoxx-22.40.tar.gz 8704952 BLAKE2B 355cd57402d3008b3b39a20bdca0cf5bd597aacf7db3dc2c379ddcc20c80ff961c0dbdf8241dd3c2161fa8d3e59618a40907dc6f4037c83089d4c1ae369f2d34 SHA512 28f4761747a144c11eb8b1b10bfc174a3a29f95a95c35f800d33c21bc12c6fa3c8b69adf714419b9ecf188c2dc7408032af44f53e2385b38b333bcb67452f9ea
+DIST fotoxx-23.0.tar.gz 9258345 BLAKE2B 96510f43c2b8a289191a1194adf13b255d29ebd8aae4e286f2fcc180bb1ecefe5df7ab9251a55e83010a527d455117ddd99dea7df189a38bc82e5b233806307e SHA512 b40025f90561c10ebb107edf26863be154c0b699c811275f2de71f9da417921704fb2215266d725a7f84b19327da54b3f9be2d00db6dfb9738739a2e9ffc1903
diff --git a/media-gfx/fotoxx/fotoxx-23.0.ebuild b/media-gfx/fotoxx/fotoxx-23.0.ebuild
new file mode 100644
index 000000000000..cd7aa63620f7
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-23.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-22.18-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}