summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-06-24 15:39:38 -0500
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-07-04 17:25:02 +0300
commit67e090339cb570cde380194dbc8b68089d9de311 (patch)
treecd8e03f68ecf67a528405a5b890d1d4203471752 /media-gfx
parentsci-mathematics/mathematica: remove Windows/MacOS-specific files (diff)
downloadgentoo-67e090339cb570cde380194dbc8b68089d9de311.tar.gz
gentoo-67e090339cb570cde380194dbc8b68089d9de311.tar.bz2
gentoo-67e090339cb570cde380194dbc8b68089d9de311.zip
media-gfx/jhead: Security bump to 3.04
EAPI bumped, src_prepare refactored away, added PATCHES array instead with a patch that includes the effects of the previous patch. This patch also includes adding Makefile functionality to create a shared library that was removed upstream since the last version we have. Bug: https://bugs.gentoo.org/701826 Bug: https://bugs.gentoo.org/711220 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16406 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/jhead/Manifest1
-rw-r--r--media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch53
-rw-r--r--media-gfx/jhead/jhead-3.04.ebuild24
3 files changed, 78 insertions, 0 deletions
diff --git a/media-gfx/jhead/Manifest b/media-gfx/jhead/Manifest
index 6cc468388b16..9a2aa890a7ef 100644
--- a/media-gfx/jhead/Manifest
+++ b/media-gfx/jhead/Manifest
@@ -1,2 +1,3 @@
DIST jhead-2.97.tar.gz 68361 BLAKE2B ed13d637dc491ad1c6ed7f9a5b0b526c80f69b8c521e3618289b16523ebb12690fa53a0a273f3f5793f970f390430d56c8504bed30fb45c5e9e2a9ac248f7667 SHA512 9b33451546e5ad3b82fe6001515fd572925a1e2c11af763ae32d71ad2cb056ffa8d97abe14bd48ae5f6144da9d8322965387537d61e22d22b02624ebf351c230
DIST jhead-3.00.tar.gz 69151 BLAKE2B 23522718f07cd0b52b3d7fbd6d0f69ca5ecd5499174b06c6572be1319b275dc93eacd270f33cd7b3380ef85e6615aa79adf1fa9a1a86404876b35c31cdb0c95e SHA512 daedfe7ea6be051f769e9a1e0946ea0fa741f387bbc5ba55eec394fb3f37b18a66aa8826190c790eb50a5b9d445ee0d5a28a08d181db3be469686b0675540fbe
+DIST jhead-3.04.tar.gz 67754 BLAKE2B 4b81927fe3db58bf10b6e42c7e045a9d8a2f50df152faf886bb28238ef74e73371d37902c3c13e6edb74a89347b2c6f698f18dd91b51797e1882cb1d3bf5461f SHA512 d783b02059ebcb01845d346e7c48bdc9d9f12fb7b0fd47bf8aff0a85a03f3523fbc536ddab0912f1c56ddb315b6cf31f16d4c7a4f81112d9a4c76a4a57ec1aed
diff --git a/media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch b/media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch
new file mode 100644
index 000000000000..0bb634b6f5b9
--- /dev/null
+++ b/media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch
@@ -0,0 +1,53 @@
+diff --git a/jhead.c b/jhead.c
+index f78127a..d8d1472 100644
+--- a/jhead.c
++++ b/jhead.c
+@@ -376,7 +376,7 @@ static void DoCommand(const char * FileName, int ShowIt)
+ // as mktemp - that is, that between getting the random name, and making the file
+ // some other program could snatch that exact same name!
+ // also, not all platforms support mkstemp.
+- mktemp(TempName);
++ mkstemp(TempName);
+
+
+ if(!TempName[0]) {
+diff --git a/makefile b/makefile
+index f8f195e..c36d34f 100644
+--- a/makefile
++++ b/makefile
+@@ -3,17 +3,20 @@
+ #--------------------------------
+ OBJ=.
+ SRC=.
+-CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+-CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+-LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
++LFLAGS = -fPIC -shared -Wl,-soname,libjhead.so.1
+
+-all: jhead
++TARGET = libjhead.so.1.0.0
++TARGET0 = libjhead.so
++TARGET1 = libjhead.so.1
++TARGET2 = libjhead.so.1.0
++
++all: jhead $(TARGET)
+
+ objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/jpgqguess.o $(OBJ)/paths.o \
+ $(OBJ)/exif.o $(OBJ)/iptc.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
+
+ $(OBJ)/%.o:$(SRC)/%.c
+- ${CC} $(CFLAGS) $(CPPFLAGS) -c $< -o $@
++ ${CC} -fPIC $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ jhead: $(objs) jhead.h
+ ${CC} $(LDFLAGS) -o jhead $(objs) -lm
+@@ -23,3 +26,9 @@ clean:
+
+ install:
+ cp jhead ${DESTDIR}/usr/bin/
++
++$(TARGET): $(objs) jhead
++ ${CC} $(LDFLAGS) $(LFLAGS) -o $(TARGET) $(objs)
++ ln -s ${TARGET} ${TARGET0}
++ ln -s ${TARGET} ${TARGET1}
++ ln -s ${TARGET} ${TARGET2}
diff --git a/media-gfx/jhead/jhead-3.04.ebuild b/media-gfx/jhead/jhead-3.04.ebuild
new file mode 100644
index 000000000000..52ccde1773de
--- /dev/null
+++ b/media-gfx/jhead/jhead-3.04.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-mkstemp-fix-makefile.patch" )
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ docinto html
+ dodoc *.html
+ doman ${PN}.1
+ doheader ${PN}.h
+ dolib.so lib${PN}.so*
+}