summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-15 21:49:26 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-15 21:56:09 -0400
commit767c32868bed135b38909818727a5ac33bb64c87 (patch)
tree3e2b0dfead8bf3b8d4abf788727ecb5d443682b5 /media-gfx
parentmedia-gfx/eog: Version bump to 40.0 (diff)
downloadgentoo-767c32868bed135b38909818727a5ac33bb64c87.tar.gz
gentoo-767c32868bed135b38909818727a5ac33bb64c87.tar.bz2
gentoo-767c32868bed135b38909818727a5ac33bb64c87.zip
media-gfx/eog-plugins: Version bump to 3.26.7
Closes: https://bugs.gentoo.org/739870 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.26.7.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index e8ce5c840712..4961bdd7f612 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-3.26.6.tar.xz 482004 BLAKE2B a70a7d1b69b7d5e6e4d44e79a4305c08ab95c06596512bf458628a65b1a8b5f7fc6c3caf39385ce722de7fdabcf0cc5e620f9dfbc53dfc377fe29252fb21a23c SHA512 67b3cfcc071ef5a196f87041039f65c9ef8e7ba2ef1cdc8dd9ea4d67f64c8b1ee0990446c5cec4fe229aabb35d106a4c0804ba6e8cbd2edfe5a91ddc3765527a
+DIST eog-plugins-3.26.7.tar.xz 482336 BLAKE2B 9cd1d7e16f8e7f1fe06c3bc2ea79ab06c397beaf9d9bfb26568ad5fb90a144ceab11f6250c7dd51ebb5d3962fff47a4c855b85725b95abca07cdc4de739a2b7e SHA512 c9312eccc5529b01cb285a165c833243ea60bb12f8be6f40ccc6da0db1bd951916000a48aa31705b048659e8d637aa7e56d761fe0f9be720a4e0ce81289d2b83
diff --git a/media-gfx/eog-plugins/eog-plugins-3.26.7.ebuild b/media-gfx/eog-plugins/eog-plugins-3.26.7.ebuild
new file mode 100644
index 000000000000..f667eae22ba1
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.26.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/share/{appdata,metainfo}
+ find "${ED}" -type f -name "*.la" -delete || die
+}