summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-10-31 20:15:44 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-10-31 20:15:52 +0100
commit7dc13b382ca650a5769697f8532ce15315e3dc9d (patch)
tree8a99a80dc3775d1b37f341872acc7699787df639 /media-gfx
parentdev-lisp/sbcl: Bumps version to 1.4.1 (diff)
downloadgentoo-7dc13b382ca650a5769697f8532ce15315e3dc9d.tar.gz
gentoo-7dc13b382ca650a5769697f8532ce15315e3dc9d.tar.bz2
gentoo-7dc13b382ca650a5769697f8532ce15315e3dc9d.zip
media-gfx/povray: Fix also openexr code for gcc-6, bug 635098
Closes: https://bugs.gentoo.org/635098 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/povray/files/povray-3.7.0.0-gcc6-openexr.patch39
-rw-r--r--media-gfx/povray/povray-3.7.0.0-r1.ebuild1
2 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/povray/files/povray-3.7.0.0-gcc6-openexr.patch b/media-gfx/povray/files/povray-3.7.0.0-gcc6-openexr.patch
new file mode 100644
index 000000000000..8b06d609402e
--- /dev/null
+++ b/media-gfx/povray/files/povray-3.7.0.0-gcc6-openexr.patch
@@ -0,0 +1,39 @@
+diff -ruN povray-3.7.0.0.orig/source/base/image/openexr.cpp povray-3.7.0.0/source/base/image/openexr.cpp
+--- povray-3.7.0.0.orig/source/base/image/openexr.cpp 2013-11-06 21:28:15.000000000 +0100
++++ povray-3.7.0.0/source/base/image/openexr.cpp 2017-10-31 20:11:28.244218318 +0100
+@@ -101,7 +101,7 @@
+
+ void write(const char *c, int n)
+ {
+- if(os.write(c, n) == false)
++ if(! os.write(c, n))
+ throw POV_EXCEPTION(kFileDataErr, "Error while writing EXR output");
+ }
+
+@@ -115,7 +115,7 @@
+
+ void seekp(Int64 pos)
+ {
+- if(os.seekg((unsigned long)pos) == false)
++ if(! os.seekg((unsigned long)pos))
+ throw POV_EXCEPTION(kFileDataErr, "Error when writing EXR output");
+ }
+ private:
+@@ -142,7 +142,7 @@
+
+ bool read(char *c, int n)
+ {
+- if(is.read(c, n) == false)
++ if(! is.read(c, n))
+ throw POV_EXCEPTION(kFileDataErr, "Error while reading EXR file");
+ return (is.tellg() < fsize);
+ }
+@@ -157,7 +157,7 @@
+
+ void seekg(Int64 pos)
+ {
+- if(is.seekg((unsigned long)pos) == false)
++ if(! is.seekg((unsigned long)pos))
+ throw POV_EXCEPTION(kFileDataErr, "Error while reading EXR file");
+ }
+ private:
diff --git a/media-gfx/povray/povray-3.7.0.0-r1.ebuild b/media-gfx/povray/povray-3.7.0.0-r1.ebuild
index 35f061a14759..ac091168ba6a 100644
--- a/media-gfx/povray/povray-3.7.0.0-r1.ebuild
+++ b/media-gfx/povray/povray-3.7.0.0-r1.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}"/${P}-user-conf.patch
"${FILESDIR}"/${P}-automagic.patch
"${WORKDIR}"/${P}_p20160914-fix-c++14.patch
+ "${FILESDIR}"/${P}-gcc6-openexr.patch
)
src_prepare() {