summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-01-08 00:46:46 -0300
committerMatt Turner <mattst88@gentoo.org>2023-01-08 12:55:32 -0500
commit84d1a1d434262cb900e0ae1727c0cec00f98c628 (patch)
treee477b112d548bd8a15a4d59000b7ec41dcea9aba /media-gfx
parentdev-python/hatch-vcs: drop 0.2.0, 0.2.1 (diff)
downloadgentoo-84d1a1d434262cb900e0ae1727c0cec00f98c628.tar.gz
gentoo-84d1a1d434262cb900e0ae1727c0cec00f98c628.tar.bz2
gentoo-84d1a1d434262cb900e0ae1727c0cec00f98c628.zip
media-gfx/eog: Version bump to 43.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog/Manifest1
-rw-r--r--media-gfx/eog/eog-43.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-gfx/eog/Manifest b/media-gfx/eog/Manifest
index 7e70699a7ecb..fc0202a7a583 100644
--- a/media-gfx/eog/Manifest
+++ b/media-gfx/eog/Manifest
@@ -1 +1,2 @@
DIST eog-43.1.tar.xz 4649476 BLAKE2B 0c7225f8f7fd60ff66469c43a0d11c15fa26956cf22706ee5d2a8c06597a8b4ef51a7d3754cde968bf2f98301d5f59326db05213217c7012fe193c57f0ce04ef SHA512 10fd4f6ad07d5a0c13931cb47c3a16d208eb6aa107f288e32fa0f1fd711d17893be9d9980fa64fa530047da131ef4e10d729421ac46d3549a9ab731be45479bc
+DIST eog-43.2.tar.xz 4655416 BLAKE2B 9909fc3da58541191b25959be20e53987f5633c97e003b0c97c4029a7cd6084d3675d75584664a023ca45897982d3cfe2668b6dc94a34b22a249b15a87307470 SHA512 aa3bb2e2684140f6a35770f6f6b80f64f09ff0f36f25ddc561c9cbbf6f22fdb4bbb1a48392a29d59dcf4852c224146ac847c62c8196e9198b34e7015bf4bb760
diff --git a/media-gfx/eog/eog-43.2.ebuild b/media-gfx/eog/eog-43.2.ebuild
new file mode 100644
index 000000000000..01a9802618ea
--- /dev/null
+++ b/media-gfx/eog/eog-43.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome https://gitlab.gnome.org/GNOME/eog"
+
+LICENSE="GPL-2+"
+SLOT="1"
+
+IUSE="+exif gtk-doc +introspection +jpeg lcms +svg xmp tiff"
+REQUIRED_USE="
+ exif? ( jpeg )
+ gtk-doc? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-0.7.4[gtk]
+ >=gnome-base/gnome-desktop-2.91.2:3=
+ >=gnome-base/gsettings-desktop-schemas-42_beta
+ >=x11-misc/shared-mime-info-0.20
+ >=x11-libs/gdk-pixbuf-2.36.5:2[jpeg?,tiff?]
+ >=x11-libs/gtk+-3.24.15:3[introspection,X]
+ >=gui-libs/libhandy-1.5.0:1
+ sys-libs/zlib
+
+ exif? ( >=media-libs/libexif-0.6.14 )
+ lcms? ( media-libs/lcms:2 )
+ xmp? ( media-libs/exempi:2= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ svg? ( >=gnome-base/librsvg-2.44.0:2 )
+
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? (
+ dev-util/gi-docgen
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif libexif)
+ $(meson_use lcms cms)
+ $(meson_use xmp)
+ $(meson_use jpeg libjpeg)
+ $(meson_use svg librsvg)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dinstalled_tests=false
+ -Dlibportal=false # As of 40.3, all libportal usages are flatpak-specific
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}