summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-11 20:17:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-11 20:20:18 +0000
commit8fc9e7a5868e52aad6625d88c89645f8058a5bb5 (patch)
treeabd6b2aa4ac111225c1967feedc46e08efc096b1 /media-gfx
parentdev-python/olefile: eapi6 switch, remove python-3 (diff)
downloadgentoo-8fc9e7a5868e52aad6625d88c89645f8058a5bb5.tar.gz
gentoo-8fc9e7a5868e52aad6625d88c89645f8058a5bb5.tar.bz2
gentoo-8fc9e7a5868e52aad6625d88c89645f8058a5bb5.zip
media-gfx/libimagequant:
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/libimagequant/Manifest1
-rw-r--r--media-gfx/libimagequant/libimagequant-2.10.1.ebuild47
-rw-r--r--media-gfx/libimagequant/metadata.xml15
3 files changed, 63 insertions, 0 deletions
diff --git a/media-gfx/libimagequant/Manifest b/media-gfx/libimagequant/Manifest
new file mode 100644
index 000000000000..c74854f01b3d
--- /dev/null
+++ b/media-gfx/libimagequant/Manifest
@@ -0,0 +1 @@
+DIST libimagequant-2.10.1.tar.gz 70783 SHA256 c06f6d33611b90b57ed362752c9fe4819f6c51896b3024010f18744dc14ce0f7 SHA512 1cbb725e5f3774f931379f640c6532e169ea02a7b502a93af6b75a305e3dab1bd34a375391be0e8fdc15fea578715e8f8319d95d674383b7048e5f73e48b106f WHIRLPOOL 654407abec0b565b9ead32b427e2393be760a012eaba8d657c4b5fd9d75f729af98be5bcdeea99487419ef91d347dbb86598f3719992401ec49ee8adcef0e9a0
diff --git a/media-gfx/libimagequant/libimagequant-2.10.1.ebuild b/media-gfx/libimagequant/libimagequant-2.10.1.ebuild
new file mode 100644
index 000000000000..2392cd1682e3
--- /dev/null
+++ b/media-gfx/libimagequant/libimagequant-2.10.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Palette quantization library that powers pngquant and other PNG optimizers"
+HOMEPAGE="https://pngquant.org/lib/"
+SRC_URI="https://github.com/ImageOptim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_sse2 debug openmp static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ tc-export AR CC
+ # Hand rolled configure script, so not all flags are supported.
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ $(use debug && echo --enable-debug) \
+ $(use_enable cpu_flags_x86_sse2 sse) \
+ $(use_with openmp) \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_compile() {
+ emake shared || die "make failed"
+ use static-libs && (emake static || die "make failed")
+}
+
+src_install() {
+ dolib.so libimagequant.so
+ dolib.so libimagequant.so.*
+ use static-libs && dolib.a libimagequant.a
+ doheader libimagequant.h
+ einstalldocs
+}
diff --git a/media-gfx/libimagequant/metadata.xml b/media-gfx/libimagequant/metadata.xml
new file mode 100644
index 000000000000..b0caaab125ff
--- /dev/null
+++ b/media-gfx/libimagequant/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>graphics@gentoo.org</email>
+ <name>Gentoo Graphics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Small, portable C library for high-quality conversion of RGBA
+ images to 8-bit indexed-color (palette) images.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ImageOptim/libimagequant</remote-id>
+ </upstream>
+</pkgmetadata>