summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-05-15 10:43:50 +0200
committerMichael Weber <xmw@gentoo.org>2017-05-15 10:44:06 +0200
commita910dddc689ee97092a4fed5008ad453d7d77fd2 (patch)
treec92aa0dd6b8c972df01f643ee4bee359c94229f3 /media-gfx
parentx11-terms/xfce4-terminal: Bump to 0.8.5.1 (diff)
downloadgentoo-a910dddc689ee97092a4fed5008ad453d7d77fd2.tar.gz
gentoo-a910dddc689ee97092a4fed5008ad453d7d77fd2.tar.bz2
gentoo-a910dddc689ee97092a4fed5008ad453d7d77fd2.zip
media-gfx/openscad: Add live ebuild.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openscad/openscad-9999.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/openscad/openscad-9999.ebuild b/media-gfx/openscad/openscad-9999.ebuild
new file mode 100644
index 000000000000..95b2d2430823
--- /dev/null
+++ b/media-gfx/openscad/openscad-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp-common eutils git-r3 qmake-utils
+
+SITEFILE="50${PN}-gentoo.el"
+
+DESCRIPTION="The Programmers Solid 3D CAD Modeller"
+HOMEPAGE="http://www.openscad.org/"
+EGIT_REPO_URI="https://github.com/openscad/openscad.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="emacs"
+
+DEPEND="media-gfx/opencsg
+ sci-mathematics/cgal
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4[-egl]
+ dev-qt/qtopengl:4[-egl]
+ dev-cpp/eigen:3
+ dev-libs/glib:2
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ dev-libs/boost:=
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/glew:*
+ media-libs/harfbuzz
+ x11-libs/qscintilla:=[qt4(-)]
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/\/usr\/local/\/usr/g" ${PN}.pro || die
+
+ default
+}
+
+src_configure() {
+ eqmake4 "${PN}.pro"
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile contrib/*.el
+ fi
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-install ${PN} contrib/*.el contrib/*.elc
+ fi
+
+ einstalldocs
+}