summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-08 23:30:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-08 23:30:45 +0200
commita91a5add21abb80f86128bd76a953ccae5cef392 (patch)
treeca0f9454ec406b0758e42e01f9beb6cf487e464b /media-gfx
parentsys-block/io-scheduler-udev-rules: Alternative way to configure I/O schedulers (diff)
downloadgentoo-a91a5add21abb80f86128bd76a953ccae5cef392.tar.gz
gentoo-a91a5add21abb80f86128bd76a953ccae5cef392.tar.bz2
gentoo-a91a5add21abb80f86128bd76a953ccae5cef392.zip
media-gfx/pngrewrite: EAPI-7 bump, https, missing slot op
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild b/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild
index 3671cefa5af1..21b31a10bea2 100644
--- a/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild
+++ b/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
-DESCRIPTION="A utility which reduces large palettes in PNG images"
-HOMEPAGE="http://entropymine.com/jason/pngrewrite/"
-SRC_URI="http://entropymine.com/jason/${PN}/${P}.zip"
+DESCRIPTION="Utility which reduces large palettes in PNG images"
+HOMEPAGE="https://entropymine.com/jason/pngrewrite/"
+SRC_URI="https://entropymine.com/jason/${PN}/${P}.zip"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
IUSE=""
-RDEPEND="media-libs/libpng"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+BDEPEND="app-arch/unzip"
+DEPEND="media-libs/libpng:0="
+RDEPEND="${DEPEND}"
-S=${WORKDIR}
+S="${WORKDIR}"
src_compile() {
emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"