summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-05-08 12:29:58 -0600
committerNicolas Bock <nicolasbock@gentoo.org>2018-05-08 13:26:51 -0600
commitb79dd7ec98a9a574fd14a4d44aacb3ccb514a02c (patch)
tree35be258e72c548728c2409c1cf532208eb1bd3a7 /media-gfx
parentdev-libs/libxslt: stable 1.1.32 for hppa, bug #637310 (diff)
downloadgentoo-b79dd7ec98a9a574fd14a4d44aacb3ccb514a02c.tar.gz
gentoo-b79dd7ec98a9a574fd14a4d44aacb3ccb514a02c.tar.bz2
gentoo-b79dd7ec98a9a574fd14a4d44aacb3ccb514a02c.zip
media-gfx/shotwell: Added shotwell-0.28.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.28.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 9469154b739c..fd6b284df7dc 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,3 +1,4 @@
DIST shotwell-0.26.4.tar.xz 5619280 BLAKE2B 0ca9ecf6e96019aa8e9bd4bae09d1b888902fc054633271854e09e1fa9b474774b7b5f2e6e3bcfed60a5b0f3ba30a2d89133d2676a94db5f4da6ee6a0af41102 SHA512 6a0772a40759d636807652ef27814306cbc2217119b071590db36c628b6e9d04f876ae1748c88476fbebc1db0c83e6a108c9f74261b7faa348c6bd37c1da198d
DIST shotwell-0.28.2.tar.xz 5582276 BLAKE2B 20d35f714543d35bd04fe81617040419664e662664ae504cbfb0b3bb160d97a5469478e1e134b6432b174fc19bb4fc370b5eb38c576c805e876d00999fb7d979 SHA512 dc00f45e55eabadaaf825de5a4152d40db2eb652f966b870a08d36006887a18aacf570b05d232a9fc7ef7df097a468a497778022bf7b86ae2143877c02540cc0
+DIST shotwell-0.28.3.tar.xz 5531900 BLAKE2B b585989434e3da9b2d5f43aabf41451e33b7b2f537a21305ff9decd9992d42e5422971d1f89836936630f641efdac1242dc21574d86f61a4c71562b657e0300d SHA512 9a0c15bfe856dabaa85038fe875cc178be6a3e104397b36555005615212ac92579234fc6277f1a4a7bddba517e9ea0db5ed06e0fc30614453e3db1153b47dc16
DIST shotwell-0.29.1.tar.xz 2368080 BLAKE2B b706229803528c55486219a4190d1145d98b513ff26a4a3d2989abd57ff3465ffab231b1779014b7babf7ce33cc875fa11905a95bbf108251c57d3692a5156a4 SHA512 25e7e7d303ecbe89ecf4eba219b6f10ad44d23209d2c2724c6d61afae47afc0a6e1a7a7fe99931888f7374419818c5d74e28bb6120383e191c038c967c84ce39
diff --git a/media-gfx/shotwell/shotwell-0.28.3.ebuild b/media-gfx/shotwell/shotwell-0.28.3.ebuild
new file mode 100644
index 000000000000..ed1f73414218
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.28.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/gcr-3[gtk]
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.10.4
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.5:=
+ >=media-libs/libraw-0.13.2:=
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ >=net-libs/libsoup-2.42.0:2.4
+ net-libs/webkit-gtk:4
+ virtual/libgudev:=[introspection]
+ >=x11-libs/gtk+-3.14.0:3[X]
+ dev-libs/libgdata
+
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ >=sys-devel/m4-1.4.13
+ virtual/pkgconfig
+"
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}