summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 06:18:06 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:53 +0300
commitbd54b70a8520f92eba4ca12e9348c389fb3deee1 (patch)
treec7c9e359e96ca410fe60195878eeae6466d71d99 /media-gfx
parentmedia-gfx/transfig: remove gcc wrapper, fix ld use (diff)
downloadgentoo-bd54b70a8520f92eba4ca12e9348c389fb3deee1.tar.gz
gentoo-bd54b70a8520f92eba4ca12e9348c389fb3deee1.tar.bz2
gentoo-bd54b70a8520f92eba4ca12e9348c389fb3deee1.zip
media-gfx/xli: fix build with -native-symlinks
Closes: https://bugs.gentoo.org/731020 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xli/xli-1.17.0-r5.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/media-gfx/xli/xli-1.17.0-r5.ebuild b/media-gfx/xli/xli-1.17.0-r5.ebuild
index 9439e0b09532..d68f42ffcf6e 100644
--- a/media-gfx/xli/xli-1.17.0-r5.ebuild
+++ b/media-gfx/xli/xli-1.17.0-r5.ebuild
@@ -23,7 +23,7 @@ RDEPEND="app-arch/bzip2
DEPEND="${RDEPEND}
app-text/rman
x11-base/xorg-proto
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
!media-gfx/xloadimage"
S=${WORKDIR}/${PN}-${SNAPSHOT}
@@ -53,8 +53,12 @@ src_prepare() {
"${FILESDIR}"/${P}-libpng14.patch
}
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+}
+
src_compile() {
- xmkmf || die
emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" EXTRA_LDOPTIONS="${LDFLAGS}"
}