summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-12 19:54:41 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-12 19:55:04 +0200
commitc0fa8b1d326f4fd0b18ad38d49336558b8d47796 (patch)
treedc5eb1d6d5ec80306ea3cd3218a88aa394e5aacb /media-gfx
parentdev-libs/elfutils: fixed USE=static-libs to install static-libs (diff)
downloadgentoo-c0fa8b1d326f4fd0b18ad38d49336558b8d47796.tar.gz
gentoo-c0fa8b1d326f4fd0b18ad38d49336558b8d47796.tar.bz2
gentoo-c0fa8b1d326f4fd0b18ad38d49336558b8d47796.zip
media-gfx/sane-frontends: EAPI 6 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/sane-frontends/files/MissingCapsFlag.patch4
-rw-r--r--media-gfx/sane-frontends/sane-frontends-1.0.14-r1.ebuild54
2 files changed, 56 insertions, 2 deletions
diff --git a/media-gfx/sane-frontends/files/MissingCapsFlag.patch b/media-gfx/sane-frontends/files/MissingCapsFlag.patch
index 4175a87f8e66..226ca085713c 100644
--- a/media-gfx/sane-frontends/files/MissingCapsFlag.patch
+++ b/media-gfx/sane-frontends/files/MissingCapsFlag.patch
@@ -1,5 +1,5 @@
---- src/gtkglue.c 2005-04-16 15:12:07.000000000 +0200
-+++ src/gtkglue.c.new 2009-06-24 00:26:46.000000000 +0200
+--- a/src/gtkglue.c 2005-04-16 15:12:07.000000000 +0200
++++ b/src/gtkglue.c 2009-06-24 00:26:46.000000000 +0200
@@ -1476,8 +1476,7 @@
|| opt->type == SANE_TYPE_GROUP || !dialog->element[i].widget)
continue;
diff --git a/media-gfx/sane-frontends/sane-frontends-1.0.14-r1.ebuild b/media-gfx/sane-frontends/sane-frontends-1.0.14-r1.ebuild
new file mode 100644
index 000000000000..26cd1d46586c
--- /dev/null
+++ b/media-gfx/sane-frontends/sane-frontends-1.0.14-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Scanner Access Now Easy"
+HOMEPAGE="http://www.sane-project.org"
+SRC_URI="ftp://ftp.sane-project.org/pub/sane/${P}/${P}.tar.gz
+ ftp://ftp.sane-project.org/pub/sane/old-versions/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gimp"
+
+RDEPEND=""
+DEPEND="media-gfx/sane-backends
+ gimp? ( media-gfx/gimp )"
+
+PATCHES=( "${FILESDIR}/MissingCapsFlag.patch" )
+
+src_configure () {
+ local myconf=""
+ use gimp || myconf="--disable-gimp"
+ use gimp && ! has_version ">=media-gfx/gimp-2" && myconf="--enable-gimp12"
+ econf \
+ --datadir=/usr/share/misc \
+ ${myconf}
+ emake
+}
+
+src_install () {
+ local gimpplugindir
+ local gimptool
+ emake DESTDIR="${D}" install
+ if use gimp; then
+ for gimptool in gimptool gimptool-2.0 gimptool-1.2; do
+ if [ -x /usr/bin/${gimptool} ]; then
+ einfo "Setting plugin link for GIMP version $(/usr/bin/${gimptool} --version)"
+ gimpplugindir=$(/usr/bin/${gimptool} --gimpplugindir)/plug-ins
+ break
+ fi
+ done
+ if [ "/plug-ins" != "${gimpplugindir}" ]; then
+ dodir ${gimpplugindir}
+ dosym /usr/bin/xscanimage ${gimpplugindir}/xscanimage
+ else
+ ewarn "No idea where to find the gimp plugin directory"
+ fi
+ fi
+ dodoc AUTHORS Changelog NEWS PROBLEMS README
+}