summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-13 09:51:38 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-13 09:59:55 +0200
commitc132ececc84829b307a8316b720f681defc252dc (patch)
tree1d8fc1aeaaf8593e62aa3d16d025cb79888c19cc /media-gfx
parentkde-frameworks/prison: metadata whitespace (diff)
downloadgentoo-c132ececc84829b307a8316b720f681defc252dc.tar.gz
gentoo-c132ececc84829b307a8316b720f681defc252dc.tar.bz2
gentoo-c132ececc84829b307a8316b720f681defc252dc.zip
media-gfx/quat: EAPI 6 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/quat/quat-1.20-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/quat/quat-1.20-r1.ebuild b/media-gfx/quat/quat-1.20-r1.ebuild
new file mode 100644
index 000000000000..9769ad572424
--- /dev/null
+++ b/media-gfx/quat/quat-1.20-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A 3D quaternionic fractal generator"
+HOMEPAGE="http://www.physcip.uni-stuttgart.de/phy11733/quat_e.html"
+SRC_URI="http://www.physcip.uni-stuttgart.de/phy11733/download/quat-1.20.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X debug"
+
+DEPEND="X? ( =x11-libs/fltk-1*
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ )
+ >=sys-libs/zlib-1.1.4"
+RDEPEND=""
+
+src_configure() {
+ export FLUID="/usr/bin/fluid" # needed because configure tries an invalid option
+ econf \
+ `use_enable X gui` \
+ `use_enable debug` \
+ `use_enable debug prof`
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+}