summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-01-17 15:25:19 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-01-17 15:25:32 +0100
commitcf7e39421c97cee7d59f77c728ffe4d0a93ac0ad (patch)
treed5dda8d0d11fc75d35fa8c09badc99291f17093e /media-gfx
parentnet-analyzer/wireshark: Update patches (diff)
downloadgentoo-cf7e39421c97cee7d59f77c728ffe4d0a93ac0ad.tar.gz
gentoo-cf7e39421c97cee7d59f77c728ffe4d0a93ac0ad.tar.bz2
gentoo-cf7e39421c97cee7d59f77c728ffe4d0a93ac0ad.zip
media-gfx/argyllcms: 2.1.2 bump
Patch for openssl 1.1 detection and TLSv1_client_method call was added upstream so we can close relevant Gentoo bug Closes: https://bugs.gentoo.org/650224 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/argyllcms/Manifest1
-rw-r--r--media-gfx/argyllcms/argyllcms-2.1.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-gfx/argyllcms/Manifest b/media-gfx/argyllcms/Manifest
index 8a494cf00a39..d4fb311ff59e 100644
--- a/media-gfx/argyllcms/Manifest
+++ b/media-gfx/argyllcms/Manifest
@@ -1 +1,2 @@
DIST Argyll_V2.1.1_src.zip 13825860 BLAKE2B c1a748cf8ecd8e04164b0281e5cfb708386b196ea75bef6be02945d1a0cd1d191d069420628612ce0bd24028e40221a988becc3eba16293555376d20ab3a4bf5 SHA512 551b90c245d15e401c96c76ec0be66053bd75ca4d8b668a41841d72197820ed27d4d0186f903c126f7bacd667170e8e45e42ad31fcd44ec3276558b87b520565
+DIST Argyll_V2.1.2_src.zip 13837053 BLAKE2B 2ad4352c79073a597ff664df8be258d56b048e1d24f677790824145f47a0b52213d219e781f8b2157f396b5a6a1d2e089d357a35ab1b8d9f58885a342f265024 SHA512 cd986db52003d12f7fc6d795cc0471d0f6a3f612f8f8c799f2824cbbd4d0ff27d215d3825222b7f2664e8f7cd3413ad46c361765c327dd5cf9f3827111155bdd
diff --git a/media-gfx/argyllcms/argyllcms-2.1.2.ebuild b/media-gfx/argyllcms/argyllcms-2.1.2.ebuild
new file mode 100644
index 000000000000..8f67157add6b
--- /dev/null
+++ b/media-gfx/argyllcms/argyllcms-2.1.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multiprocessing toolchain-funcs udev
+
+MY_P="Argyll_V${PV}"
+
+DESCRIPTION="Open source, ICC compatible color management system"
+HOMEPAGE="http://www.argyllcms.com/"
+SRC_URI="http://www.argyllcms.com/${MY_P}_src.zip"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="doc libressl"
+
+RDEPEND="
+ media-libs/tiff:0
+ sys-libs/zlib
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ x11-libs/libXScrnSaver
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/ftjam"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # Make it respect LDFLAGS
+ echo "LINKFLAGS += ${LDFLAGS} ;" >> Jamtop
+
+ # Evil hack to get --as-needed working. The build system unfortunately lists all
+ # the shared libraries by default on the command line _before_ the object to be built...
+ echo "STDLIBS += -ldl -lrt -lX11 -lXext -lXxf86vm -lXinerama -lXrandr -lXau -lXdmcp -lXss -ltiff -ljpeg ;" >> Jamtop
+
+ append-cflags -DUNIX -D_THREAD_SAFE
+
+ sed \
+ -e 's:CCFLAGS:CFLAGS:g' \
+ -e "s:ar rusc:$(tc-getAR) rusc:g" \
+ -i Jambase || die
+
+ tc-export CC RANLIB
+
+ jam -dx -fJambase "-j$(makeopts_jobs)" || die
+}
+
+src_install() {
+ jam -dx -fJambase install || die
+
+ rm bin/License.txt || die
+
+ pushd bin > /dev/null
+ local binname
+ for binname in * ; do
+ newbin ${binname} argyll-${binname}
+ done
+ popd > /dev/null
+
+ dodoc log.txt Readme.txt ttbd.txt notes.txt
+ if use doc; then
+ docinto html
+ dodoc doc/*html doc/*jpg doc/*gif
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r ref
+
+ udev_dorules usb/55-Argyll.rules
+}
+
+pkg_postinst() {
+ elog "If you have a Spyder2 you need to extract the firmware"
+ elog "from the CVSpyder.dll of the windows driver package"
+ elog "and store it as /usr/share/color/spyd2PLD.bin"
+ echo
+ elog "For further info on setting up instrument access read"
+ elog "http://www.argyllcms.com/doc/Installing_Linux.html"
+ echo
+}