summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2022-12-22 17:57:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-01-07 18:43:29 +0200
commitd317620a6e788ca6a9a5df0a291254f8a4c515b8 (patch)
tree7501173bb56fbd05ef9c3bea5477a51f3067d0fe /media-gfx
parentmedia-gfx/hydrus: Drop 497-r1 (diff)
downloadgentoo-d317620a6e788ca6a9a5df0a291254f8a4c515b8.tar.gz
gentoo-d317620a6e788ca6a9a5df0a291254f8a4c515b8.tar.bz2
gentoo-d317620a6e788ca6a9a5df0a291254f8a4c515b8.zip
media-gfx/hydrus: Add 511
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hydrus/Manifest1
-rw-r--r--media-gfx/hydrus/hydrus-511.ebuild149
2 files changed, 150 insertions, 0 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index b97158a2b5ff..b50e50de9f36 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -1,3 +1,4 @@
DIST hydrus-501.tar.gz 40724774 BLAKE2B 6a93c4483b07e976fac829aee4c1f4c879f535ff0ce7e89c64b278bc3f7d77abdd9b906d48f87b175a1eccec2dcf962725abe0602fb68b009fbba9d0f3381067 SHA512 1c9275023f1d205bf916eb85566237fe8f25a446399065ebc371e1db8ca3c3e2501e8a82867e9f7711b007a74a9e88d838babca29a2556d19ffcf77b14182834
DIST hydrus-505.tar.gz 40756022 BLAKE2B a5d9cfd5f8023a2f809c2610c48e8018ca7bb6002d1420485e463b3fe477cae07a2f4ea2cd823ff592a164d37e611938fe805d163cbf5512c636b972c1afad77 SHA512 f5c818616aa195b904d5cd65e77f29095f22fc9f435b0218110cb47e655c004c3ce3e72fc9de8ec8b1e9b508ced42b045131e0ddd6442fa43fc7d4d77877465e
DIST hydrus-510.tar.gz 40813887 BLAKE2B 84ecc40897e0aa324005d05146ea1ac439e9576a376ab40641a948ddeb2a58b7f171a0b9c00f69bd34b218e195c8b77c505992c0b51372454bc3c8208f1ef485 SHA512 998cdd09bcbb8bf3ba611754f5237d5a743e89988bf3259ae7187ac8730e6183b433622c25fef400c0efdc9fd38dcbfa171e70da5be953557983d08f15c8b21e
+DIST hydrus-511.tar.gz 40821597 BLAKE2B 15bff5bf7427ddef3a3700a883d0afe83090844c2052c41b1c4bfc13bce1f0052d48cc452d7e779c8b42a9a0d68901d27e750673ca2414c209db1c1fcd67a427 SHA512 d48d8e31b4eab80db917ebe6fe5ece719644e1b06ec8ca063a20044b39ad695b90c00340850be42c69ee163ab8866c0925c90752c74fdfbf40643dc02658b813
diff --git a/media-gfx/hydrus/hydrus-511.ebuild b/media-gfx/hydrus/hydrus-511.ebuild
new file mode 100644
index 000000000000..03954ae38a2f
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-511.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+DOCS_BUILDER=mkdocs
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit python-single-r1 desktop docs optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+else
+ SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+# RDEPEND is sorted as such:
+# - No specific requirements
+# - Specific version or slot
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/cbor2[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cloudscraper[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyside2[widgets,gui,${PYTHON_USEDEP}]
+ dev-python/python-mpv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
+ media-video/ffmpeg
+ media-video/mpv[libmpv,${PYTHON_USEDEP}]
+
+ >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/userpath-in-local-share.patch"
+)
+
+src_prepare() {
+ default
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Build files used for CI and development, not actually needed
+ rm -r static/build_files static/requirements || die
+ # Python requirements file, not needed
+ rm requirements.txt || die
+ # Remove unneeded additional scripts
+ rm *.command *.sh *.bat || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+ docs_compile
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ local -x QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+}
+
+src_install() {
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${doc}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
+ einstalldocs
+
+ # Files only needed for testing
+ rm test.py hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ static/testing/ || die
+
+ # ${DOCS[@]} files are copied into doc
+ # ${S}/docs/ is the markdown source code for documentation
+ # .gitignore/.github files aren't needed for the program to work, same with mkdocs files
+ rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
+ if use doc; then
+ # ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
+ rm -r "${S}/_build" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ dosym "${doc}/html" /opt/hydrus/help
+ fi
+
+ insinto /opt/hydrus
+ doins -r "${S}"/.
+
+ exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" || die)
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" || die)
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "automatic port forwarding support" "net-libs/miniupnpc"
+ optfeature "bandwidth charts support" "dev-python/pyside2[charts]"
+ optfeature "memory compression in the client" "dev-python/lz4"
+ optfeature "SOCKS proxy support" "dev-python/requests[socks5]" "dev-python/PySocks"
+}