summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-10-17 11:38:58 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-10-17 12:36:57 +0200
commited35482993ed0d3645c9f394a58685faef8bd507 (patch)
tree0ad1d8a11aa3b1190249fdd51baf68c8a63c9314 /media-gfx
parentmedia-gfx/displaycal: drop old (diff)
downloadgentoo-ed35482993ed0d3645c9f394a58685faef8bd507.tar.gz
gentoo-ed35482993ed0d3645c9f394a58685faef8bd507.tar.bz2
gentoo-ed35482993ed0d3645c9f394a58685faef8bd507.zip
media-gfx/displaycal: 3.8.7.1 bump
python3 and wxpython4 support will have to wait for upcoming release Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.8.7.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
index e2301027fcb0..e57d1b6c9a97 100644
--- a/media-gfx/displaycal/Manifest
+++ b/media-gfx/displaycal/Manifest
@@ -1 +1,2 @@
DIST DisplayCAL-3.8.7.0.tar.gz 10619677 BLAKE2B 9b697d3548bd3a2a7a5f2bb38589bdd7e67ff964b613371a83ae11ec1a114874283d67a442f4336a1d50e86fe127ae755ea68865de112ea83520def404a6e715 SHA512 f47cda64648ef59c211aa54993ee423e80caf26f8942de88672e430bec7976d83f15c58fe9df8217217be48a1b36e8c3342fc3baf862077fe229da214fd38400
+DIST DisplayCAL-3.8.7.1.tar.gz 10621039 BLAKE2B be4e350a63efb615a363aea36e4e92bc837d0021088ab28f78e92ba0743af5e3930812c1154d32ff06d301461d44b50b483ea15e6954943204974cc264918057 SHA512 67f49b3ae85620f9e9c7e9d4162538f78ab160a590e6cb95f78203045e0d2d8d604abe3ab533030e9359d70292a8b7dd02174c99b3143fabd7ca27a3b07a5626
diff --git a/media-gfx/displaycal/displaycal-3.8.7.1.ebuild b/media-gfx/displaycal/displaycal-3.8.7.1.ebuild
new file mode 100644
index 000000000000..6d9baac97b2a
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.8.7.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-libs/libXinerama-1.1
+"
+RDEPEND="${DEPEND}
+ dev-python/faulthandler[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.2.1[${PYTHON_USEDEP}]
+"
+
+# Just in case someone renames the ebuild
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Do not generate udev/hotplug files
+ sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
+ -i DisplayCAL/setup.py || die
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
+ -e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
+ -i DisplayCAL/postinstall.py || die
+
+ # Remove deprecated Encoding key from .desktop file
+ sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die
+
+ # Remove x-world Media Type
+ sed -e 's/x\-world\/x\-vrml\;//g' \
+ -i misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}