summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-06 15:48:14 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-06 15:48:14 +0200
commiteefc2342f65773e3d7aeee2f5af43a10e6616bda (patch)
tree9e57053cddba5abb7b03707496f5945adf4131d3 /media-gfx
parentwww-misc/multisort: Shorter DESCRIPTION (diff)
downloadgentoo-eefc2342f65773e3d7aeee2f5af43a10e6616bda.tar.gz
gentoo-eefc2342f65773e3d7aeee2f5af43a10e6616bda.tar.bz2
gentoo-eefc2342f65773e3d7aeee2f5af43a10e6616bda.zip
media-gfx/peps: eapi bump to 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/peps/peps-2.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/peps/peps-2.0-r1.ebuild b/media-gfx/peps/peps-2.0-r1.ebuild
new file mode 100644
index 000000000000..8b79fa61acf1
--- /dev/null
+++ b/media-gfx/peps/peps-2.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Preprocess and convert EPS files to bitmap with Ghostscript"
+HOMEPAGE="http://peps.redprince.net/peps/"
+SRC_URI="http://www.peps.redprince.net/peps/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="app-text/ghostscript-gpl
+ app-arch/gzip"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use X && ! grep -q x11gray4 <(gs -h 2>/dev/null); then
+ die "you need a ghostscript version with 'x11' and 'x11gray4' devices!"
+ fi
+}
+
+src_prepare() {
+ default
+ # adding <string.h> include
+ sed -i -e "s:^\(#include.*<unistd.h>.*\):\1\n#include <string.h>:" peps.c || die
+ # adding LDFLAGS to Makefile
+ sed -i -e "s:\( -o \): \${LDFLAGS}\1:g" Makefile || die
+}
+
+src_compile() {
+ local myopts="peps"
+ use X && myopts="${myopts} xpeps"
+ emake CC="$(tc-getCC)" ${myopts}
+}
+
+src_install() {
+ # manual install, because fixing dumb Makefile is more compilcated
+ dobin peps
+ use X && dobin xpeps
+
+ doman peps.1
+ dodoc README
+
+ insinto /etc
+ doins peps.mime
+
+ # copy PDF so it won't be compressed
+ cp peps.pdf "${D}usr/share/doc/${PF}" || die
+}