summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Gstädtner <thomas@gstaedtner.net>2017-11-12 21:57:02 +0100
committerJonas Stein <jstein@gentoo.org>2017-11-13 20:55:25 +0100
commitfb22e64161356b145266c144200dfafc7fcbdcf3 (patch)
treeb3e962e419488b3e8881cbe98e2df49db4419a52 /media-gfx
parentapp-editors/le: Bump to 1.16.5 (diff)
downloadgentoo-fb22e64161356b145266c144200dfafc7fcbdcf3.tar.gz
gentoo-fb22e64161356b145266c144200dfafc7fcbdcf3.tar.bz2
gentoo-fb22e64161356b145266c144200dfafc7fcbdcf3.zip
media-gfx/sigal: new package
Adds new package media-gfx/sigal to the tree. Closes: https://bugs.gentoo.org/536864 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/sigal/Manifest1
-rw-r--r--media-gfx/sigal/metadata.xml31
-rw-r--r--media-gfx/sigal/sigal-1.3.0.ebuild33
3 files changed, 65 insertions, 0 deletions
diff --git a/media-gfx/sigal/Manifest b/media-gfx/sigal/Manifest
new file mode 100644
index 000000000000..a960ba3b169f
--- /dev/null
+++ b/media-gfx/sigal/Manifest
@@ -0,0 +1 @@
+DIST sigal-1.3.0.tar.gz 3267422 SHA256 71074e29bdede46866a46502629f7165057d269c1b63b5fba0dc40d029926059 SHA512 132c94a472301a2cc81a4aef13afa8137a6b69dfc035821e22fca6b0598cb94f1788f1a8cf1b47412214c9480867be816070aaa938290a1d10bccc407c38aaf4 WHIRLPOOL 833aad3f72cd298c5f6ae8172845b3fbec709686ec1b2ee0537f06bff1b1af53b7ec5f0d94880a2058512817f6ec14752dbf963cf0506efc9c49f3725b5a9dc7
diff --git a/media-gfx/sigal/metadata.xml b/media-gfx/sigal/metadata.xml
new file mode 100644
index 000000000000..8a8f5b028e46
--- /dev/null
+++ b/media-gfx/sigal/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>thomas@gstaedtner.net</email>
+ <name>Thomas Gstädtner</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Sigal is yet another simple static gallery generator.
+ It's written in Python and it allows to build a static gallery
+ of images with the following features:
+ - Process directories recursively.
+ - Generate HTML pages using jinja2 templates.
+ - Relative links for a portable output.
+ - Support themes, videos, EXIF tags, zip download.
+ - Parallel processing.
+ - MIT licensed.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sigal</remote-id>
+ <remote-id type="github">saimn/sigal</remote-id>
+ <bugs-to>https://github.com/saimn/sigal/issues</bugs-to>
+ </upstream>
+ <use>
+ <flag name="s3">Enables support for the Amazon S3 service.</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-gfx/sigal/sigal-1.3.0.ebuild b/media-gfx/sigal/sigal-1.3.0.ebuild
new file mode 100644
index 000000000000..735f9a67f9f2
--- /dev/null
+++ b/media-gfx/sigal/sigal-1.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple static web gallery generator"
+HOMEPAGE="http://sigal.saimon.org/"
+SRC_URI="https://github.com/saimn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="s3 test"
+
+CDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pilkit[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="${CDEPEND}"
+
+DOCS="README.rst"
+
+python_test() {
+ esetup.py test
+}