summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2020-10-06 00:04:26 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2020-10-06 00:06:56 +0200
commit23b04b0d1462ca6efe5780edd27cefb423260153 (patch)
tree1a296f230dca2a1418f03674ef535501c07060f1 /media-libs/SoQt
parentdev-lang/python: Bump to 3.10.0a1 (diff)
downloadgentoo-23b04b0d1462ca6efe5780edd27cefb423260153.tar.gz
gentoo-23b04b0d1462ca6efe5780edd27cefb423260153.tar.bz2
gentoo-23b04b0d1462ca6efe5780edd27cefb423260153.zip
media-libs/SoQt: re-add package
Closes: https://bugs.gentoo.org/686972 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'media-libs/SoQt')
-rw-r--r--media-libs/SoQt/Manifest1
-rw-r--r--media-libs/SoQt/SoQt-1.6.0.ebuild48
-rw-r--r--media-libs/SoQt/metadata.xml16
3 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/SoQt/Manifest b/media-libs/SoQt/Manifest
new file mode 100644
index 000000000000..4b5188f20ea8
--- /dev/null
+++ b/media-libs/SoQt/Manifest
@@ -0,0 +1 @@
+DIST SoQt-1.6.0-src.tar.gz 1675532 BLAKE2B 9935c32a7f0ad0d0e4248c6f81d2aacad00f3674d8e14aa192a87be5dc3b99e29213fbd96044ad4cc6548aef7f1d281aadebc48256bbfc11ad305e2136f6e12a SHA512 4221e98f51cca4dda23043428e869b60ab4d994710f97c0f44cd82631ffad2bd8bbaf0b820434a4636892df663d66ecd2aec14b185972671b2d22c0fe242b553
diff --git a/media-libs/SoQt/SoQt-1.6.0.ebuild b/media-libs/SoQt/SoQt-1.6.0.ebuild
new file mode 100644
index 000000000000..987b9268d17c
--- /dev/null
+++ b/media-libs/SoQt/SoQt-1.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+MY_P=${P/soqt/SoQt}
+
+HOMEPAGE="https://github.com/coin3d/coin/wiki"
+DESCRIPTION="GUI binding for using Coin/Open Inventor with Qt"
+SRC_URI="https://github.com/coin3d/soqt/releases/download/${MY_P}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc"
+
+RDEPEND="
+ media-libs/coin
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtopengl:5
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXi
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ doc? ( app-doc/doxygen )
+"
+
+S="${WORKDIR}/soqt"
+
+DOCS=(AUTHORS ChangeLog HACKING NEWS README)
+
+src_configure() {
+ use debug && append-cppflags -DSOQT_DEBUG=1
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DSOQT_BUILD_DOCUMENTATION=$(usex doc)
+ -DSOQT_BUILD_INTERNAL_DOCUMENTATION=OFF
+ -DSOQT_VERBOSE=$(usex debug)
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/SoQt/metadata.xml b/media-libs/SoQt/metadata.xml
new file mode 100644
index 000000000000..4b5cc76b6e9c
--- /dev/null
+++ b/media-libs/SoQt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>reavertm@gentoo.org</email>
+ <description>Feel free to maintain/fix</description>
+ </maintainer>
+ <longdescription lang="en">
+ SoQt is a Qt GUI component toolkit library for Coin. It is also compatible
+ with SGI and TGS Open Inventor, and the API is based on the API of the
+ InventorXt GUI component toolkit.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">coin3d/soqt</remote-id>
+ </upstream>
+</pkgmetadata>