summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-09-05 18:11:14 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-09-05 18:12:21 -0400
commita1115b15ff396d0096dade43aba4fa5faa1a0826 (patch)
tree568c38b29466f3281cdd23b30a6d63d97129d29b /media-libs/aften/files
parentdev-python/pyopenssl: Version bump to 16.1.0 (diff)
downloadgentoo-a1115b15ff396d0096dade43aba4fa5faa1a0826.tar.gz
gentoo-a1115b15ff396d0096dade43aba4fa5faa1a0826.tar.bz2
gentoo-a1115b15ff396d0096dade43aba4fa5faa1a0826.zip
media-libs/aften: new revision with dynamically-linked executable.
This new revision includes a tiny patch from Gentoo user Ihar Hrachyshka. The upstream build system defaults to building a target called "aften_static", and all we need to do is change that to "aften" to get the dynamically-linked version. Non-maintainer commit with permission from David Seifert (soap). Gentoo-Bug: 258397 Package-Manager: portage-2.2.28
Diffstat (limited to 'media-libs/aften/files')
-rw-r--r--media-libs/aften/files/aften-0.0.8-no-static-aften.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/media-libs/aften/files/aften-0.0.8-no-static-aften.patch b/media-libs/aften/files/aften-0.0.8-no-static-aften.patch
new file mode 100644
index 000000000000..66cb18d3d445
--- /dev/null
+++ b/media-libs/aften/files/aften-0.0.8-no-static-aften.patch
@@ -0,0 +1,15 @@
+Patch from user Ihar Hrachyshka on Gentoo bug 258397. Replaces the
+"aften_static" target with "aften" which is dynamically linked.
+
+diff -urN aften-0.0.8.orig/CMakeLists.txt aften-0.0.8/CMakeLists.txt
+--- a/CMakeLists.txt 2007-09-08 04:51:47.000000000 +0300
++++ b/CMakeLists.txt 2009-08-30 22:56:00.000000000 +0300
+@@ -278,7 +278,7 @@
+ # When linking to static aften, dllimport mustn't be used
+ SET_TARGET_PROPERTIES(aften_exe PROPERTIES COMPILE_FLAGS -DAFTEN_BUILD_LIBRARY)
+ ENDIF(WIN32)
+-TARGET_LINK_LIBRARIES(aften_exe aften_pcm aften_static)
++TARGET_LINK_LIBRARIES(aften_exe aften_pcm aften)
+
+ ADD_EXECUTABLE(wavinfo util/wavinfo.c)
+ TARGET_LINK_LIBRARIES(wavinfo aften_pcm)