summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/aldumb/aldumb-0.9.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/aldumb/aldumb-0.9.3.ebuild')
-rw-r--r--media-libs/aldumb/aldumb-0.9.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/aldumb/aldumb-0.9.3.ebuild b/media-libs/aldumb/aldumb-0.9.3.ebuild
new file mode 100644
index 000000000000..c9de984ae80a
--- /dev/null
+++ b/media-libs/aldumb/aldumb-0.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Allegro support for DUMB (an IT, XM, S3M, and MOD player library)"
+HOMEPAGE="http://dumb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dumb/dumb-${PV}.tar.gz"
+
+LICENSE="DUMB-0.9.2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+DEPEND=">=media-libs/dumb-0.9.3
+ <media-libs/allegro-5"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P/aldumb/dumb}"
+
+src_prepare() {
+ cat << EOF > make/config.txt
+include make/unix.inc
+ALL_TARGETS := allegro allegro-examples allegro-headers
+PREFIX := /usr
+EOF
+ epatch "${FILESDIR}"/${P}-PIC-as-needed.patch
+ epatch "${FILESDIR}"/${P}_CVE-2006-3668.patch
+ sed -i '/= -s/d' Makefile || die "sed failed"
+ cp -f Makefile Makefile.rdy
+}
+
+src_compile() {
+ emake OFLAGS="${CFLAGS}" all || die "emake failed"
+}
+
+src_install() {
+ dobin examples/dumbplay
+ dolib.so lib/unix/libaldmb.so
+
+ use debug && lib/unix/libaldmd.so
+
+ insinto /usr/include
+ doins include/aldumb.h
+}