summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-06-20 20:21:00 +0200
committerSam James <sam@gentoo.org>2021-11-07 00:01:17 +0000
commit4f0450984b3a5827e10e3701c40e9f75b992a301 (patch)
tree9564c921f21082906ff6521c5f09d5324cc2ec49 /media-libs/avidemux-core
parentmedia-libs/avidemux-plugins: bump to 2.7.8 (diff)
downloadgentoo-4f0450984b3a5827e10e3701c40e9f75b992a301.tar.gz
gentoo-4f0450984b3a5827e10e3701c40e9f75b992a301.tar.bz2
gentoo-4f0450984b3a5827e10e3701c40e9f75b992a301.zip
media-libs/avidemux-core: bump to 2.7.8
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/avidemux-core')
-rw-r--r--media-libs/avidemux-core/Manifest1
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.7.8.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/media-libs/avidemux-core/Manifest b/media-libs/avidemux-core/Manifest
index d9b9b78a2a09..9fc07834baab 100644
--- a/media-libs/avidemux-core/Manifest
+++ b/media-libs/avidemux-core/Manifest
@@ -1 +1,2 @@
DIST avidemux-2.7.6.tar.gz 21963753 BLAKE2B 6ca343f90c37844ebfd61123badccefb7327cbf500723c031257cf26500a5b6d98955568c2a9c0d182af68f162e878459a51e6049485937f9b01b4439b32e5e0 SHA512 bc60c733168d40d5b39cc7dd1f74b3f1315e9727302478ef1621e18748bad3400bcfd4d5199862c3093ad9df51385b6b2a96f0f8fedf9bf1c00060327545fb0f
+DIST avidemux-2.7.8.tar.gz 22080267 BLAKE2B a1e56856f44d56afac6ea4015f206a3f9301c025b3c8da1528165bd4c139ccc971074ac21aa05b9b3dfd6d514eabcbb375e671c8df9c9e5cae74a0a6597577c4 SHA512 6cd5527ab34517a07bf73e46d01f15b7ff023ff34ed70ee54f1d7dbfb6cf57364a323b4ecb89bb9aadeb9bc05473aacb40d8c4eecc522840a3c1c4b3a8756d82
diff --git a/media-libs/avidemux-core/avidemux-core-2.7.8.ebuild b/media-libs/avidemux-core/avidemux-core-2.7.8.ebuild
new file mode 100644
index 000000000000..f1b9a125c6c1
--- /dev/null
+++ b/media-libs/avidemux-core/avidemux-core-2.7.8.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake flag-o-matic toolchain-funcs
+
+DESCRIPTION="Core libraries for simple video cutting, filtering and encoding tasks"
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+SRC_URI="https://github.com/mean00/avidemux2/archive/${PV}.tar.gz -> avidemux-${PV}.tar.gz"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+SLOT="2.7"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls nvenc sdl system-ffmpeg vaapi vdpau xv"
+
+# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
+DEPEND="
+ dev-db/sqlite:3
+ nvenc? ( media-video/nvidia_video_sdk )
+ sdl? ( media-libs/libsdl:0 )
+ system-ffmpeg? ( >=media-video/ffmpeg-9:0[mp3,theora] )
+ vaapi? ( x11-libs/libva:0= )
+ vdpau? ( x11-libs/libvdpau:0 )
+ xv? ( x11-libs/libXv:0 )
+"
+RDEPEND="
+ ${DEPEND}
+ !<media-libs/avidemux-core-${PV}
+ !<media-video/avidemux-${PV}
+ nls? ( virtual/libintl:0 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ !system-ffmpeg? ( dev-lang/yasm[nls=] )
+"
+
+PATCHES=( "${FILESDIR}"/avidemux-core-2.7.6-ffmpeg-flags.patch )
+
+S="${WORKDIR}/avidemux2-${PV}"
+CMAKE_USE_DIR="${S}/${PN/-/_}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use system-ffmpeg ; then
+ # Preparations to support the system ffmpeg. Currently fails because
+ # it depends on files the system ffmpeg doesn't install.
+ local error="Failed to remove bundled ffmpeg."
+
+ rm -r cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
+ sed -e 's/include(admFFmpegUtil)//g' -e '/registerFFmpeg/d' -i avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -e 's/include(admFFmpegBuild)//g' -i avidemux_core/CMakeLists.txt || die "${error}"
+ else
+ local ffmpeg_args=(
+ --cc=$(tc-getCC)
+ --cxx=$(tc-getCXX)
+ --ar=$(tc-getAR)
+ --nm=$(tc-getNM)
+ --ranlib=$(tc-getRANLIB)
+ "--optflags='${CFLAGS}'"
+ )
+
+ sed -i -e "s/@@GENTOO_FFMPEG_FLAGS@@/${ffmpeg_args[*]}/" cmake/ffmpeg_configure.sh.cmake || die
+ fi
+}
+
+src_configure() {
+ # See bug 432322.
+ use x86 && replace-flags -O0 -O1
+ # Bug 768210
+ append-cxxflags -std=gnu++14
+
+ local mycmakeargs=(
+ -DAVIDEMUX_SOURCE_DIR='${S}'
+ -DGETTEXT="$(usex nls)"
+ -DNVENC="$(usex nvenc)"
+ -DSDL="$(usex sdl)"
+ -DLIBVA="$(usex vaapi)"
+ -DVDPAU="$(usex vdpau)"
+ -DXVIDEO="$(usex xv)"
+ )
+
+ use debug && mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+}