summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-12-29 02:02:08 +0300
committerSam James <sam@gentoo.org>2020-12-29 01:54:42 +0000
commit9dc282fb7b31e7f7beb5e63c8846e5b0721375d5 (patch)
treebe09c824d5659f5cbfbfbaefefbd396b4a5ff705 /media-libs/babl/babl-0.1.84.ebuild
parentmedia-libs/babl: 9999, sse3 meson option is removed (diff)
downloadgentoo-9dc282fb7b31e7f7beb5e63c8846e5b0721375d5.tar.gz
gentoo-9dc282fb7b31e7f7beb5e63c8846e5b0721375d5.tar.bz2
gentoo-9dc282fb7b31e7f7beb5e63c8846e5b0721375d5.zip
media-libs/babl: 0.1.84 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/babl/babl-0.1.84.ebuild')
-rw-r--r--media-libs/babl/babl-0.1.84.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/babl/babl-0.1.84.ebuild b/media-libs/babl/babl-0.1.84.ebuild
new file mode 100644
index 000000000000..cd9637db7829
--- /dev/null
+++ b/media-libs/babl/babl-0.1.84.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_USE_DEPEND=vapigen
+
+inherit meson gnome2-utils vala
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/babl.git"
+ SRC_URI=""
+else
+ SRC_URI="https://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="https://gegl.org/babl/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="introspection lcms vala cpu_flags_x86_avx2 cpu_flags_x86_f16c cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse4_1"
+REQUIRED_USE="vala? ( introspection )"
+
+BDEPEND="
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+RDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ lcms? ( >=media-libs/lcms-2.8:2 )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ local emesonargs=(
+ -Dwith-docs=false
+ $(meson_use introspection enable-gir)
+ $(meson_use lcms with-lcms)
+ $(meson_use vala enable-vapi)
+ $(meson_use cpu_flags_x86_avx2 enable-avx2)
+ $(meson_use cpu_flags_x86_f16c enable-f16c)
+ $(meson_use cpu_flags_x86_mmx enable-mmx)
+ $(meson_use cpu_flags_x86_sse enable-sse)
+ $(meson_use cpu_flags_x86_sse2 enable-sse2)
+ $(meson_use cpu_flags_x86_sse4_1 enable-sse4_1)
+ )
+ meson_src_configure
+}