summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-24 01:40:36 +0000
committerSam James <sam@gentoo.org>2020-11-24 01:40:36 +0000
commit8915a41abcce15383892a470da2a7c55b718f790 (patch)
tree49c0a0aee1a7a1a4ee13fc17dc35f332b5ea0a25 /media-libs/bcg729
parentsys-process/parallel: bump to 20201122 (diff)
downloadgentoo-8915a41abcce15383892a470da2a7c55b718f790.tar.gz
gentoo-8915a41abcce15383892a470da2a7c55b718f790.tar.bz2
gentoo-8915a41abcce15383892a470da2a7c55b718f790.zip
media-libs/bcg729: bump to 1.1.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/bcg729')
-rw-r--r--media-libs/bcg729/Manifest1
-rw-r--r--media-libs/bcg729/bcg729-1.1.1.ebuild23
-rw-r--r--media-libs/bcg729/bcg729-999999.ebuild23
3 files changed, 31 insertions, 16 deletions
diff --git a/media-libs/bcg729/Manifest b/media-libs/bcg729/Manifest
index 1beae9d37e78..c4e776d5f22d 100644
--- a/media-libs/bcg729/Manifest
+++ b/media-libs/bcg729/Manifest
@@ -1 +1,2 @@
DIST bcg729-1.0.4.tar.gz 115641 BLAKE2B 5240fc10f8c4c32d9c9a6fc527a198fc896a8ff5ea12aa8a692808877582ac25b3fee122799cb7f6cea58db2f07cc07348da36d9f526e62f0bf62d61ef33bcfa SHA512 fdbbd2c9a807ed832ac3976301843bae854368ab281d16f792550bbda921d226fc6003c0a499561529f22eae08bc0d78b8826c2d06c859ab706d999a96967ffb
+DIST bcg729-1.1.1.tar.gz 122475 BLAKE2B 6774f6af439c9308db856be9d4bbb6db5c73e7a807b51dca6338d1506d896052a7830ade7767b45fd5a9ded0a6a0057e207bc1d5b0e33adbaed9dafb13a7bd3b SHA512 e8cc4b7486a9a29fb729ab9fd9e3c4a2155573f38cec16f5a53db3b416fc1119ea5f5a61243a8d37cb0b64580c5df1b632ff165dc7ff47421fa567dafffaacd8
diff --git a/media-libs/bcg729/bcg729-1.1.1.ebuild b/media-libs/bcg729/bcg729-1.1.1.ebuild
new file mode 100644
index 000000000000..ed8001bbde04
--- /dev/null
+++ b/media-libs/bcg729/bcg729-1.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
+HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
+SRC_URI="https://github.com/BelledonneCommunications/bcg729/archive/${PV/_/-}.tar.gz \
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="!media-plugins/mediastreamer-bcg729"
+
+src_install() {
+ cmake_src_install
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/bcg729/bcg729-999999.ebuild b/media-libs/bcg729/bcg729-999999.ebuild
index 4155676ac3c2..5263aff5d73a 100644
--- a/media-libs/bcg729/bcg729-999999.ebuild
+++ b/media-libs/bcg729/bcg729-999999.ebuild
@@ -1,33 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils git-r3
+
+inherit cmake git-r3
DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
EGIT_REPO_URI="https://github.com/BelledonneCommunications/bcg729"
+S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="static-libs"
-RDEPEND="
- !media-plugins/mediastreamer-bcg729
-"
-S=${WORKDIR}/${P/_/-}
+RDEPEND="!media-plugins/mediastreamer-bcg729"
+
PATCHES=(
"${FILESDIR}"/${PN}-4.3.0_beta-cmake-build.patch
)
-src_configure() {
- mycmakeargs=(
- -DENABLE_STATIC=$(usex static-libs)
- )
- cmake-utils_src_configure
-}
-
src_install() {
- cmake-utils_src_install
+ cmake_src_install
find "${ED}" -name '*.la' -delete || die
}