summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-08-14 09:11:08 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-08-14 09:11:14 +0200
commit2f99ab53de19c6d8d97ee346f1c653ae0722885d (patch)
tree47137e0713ac39c03f839d1d8505f4d61c570268 /media-libs/codec2/codec2-1.0.0.ebuild
parentmedia-sound/ardour: bump to 6.9 (diff)
downloadgentoo-2f99ab53de19c6d8d97ee346f1c653ae0722885d.tar.gz
gentoo-2f99ab53de19c6d8d97ee346f1c653ae0722885d.tar.bz2
gentoo-2f99ab53de19c6d8d97ee346f1c653ae0722885d.zip
media-libs/codec2: bump to 1.0.0 + updated homepage
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/codec2/codec2-1.0.0.ebuild')
-rw-r--r--media-libs/codec2/codec2-1.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/codec2/codec2-1.0.0.ebuild b/media-libs/codec2/codec2-1.0.0.ebuild
new file mode 100644
index 000000000000..b90705d61a95
--- /dev/null
+++ b/media-libs/codec2/codec2-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ https://www.rowetel.com/?page_id=452 https://github.com/drowe67/codec2"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+# Not yet passing, but infrastructure added to run
+RESTRICT="test"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNITTEST=$(usex test)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+ cmake_src_configure
+}