summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-08 18:54:17 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-08 18:54:17 +0200
commitc9843a298647c9fd076a4fb54320cdf8a47466ae (patch)
tree67eb0b82d39fb3e16342e80eebc7ad110a23edae /media-libs/codec2
parentmedia-sound/pitchtune: Fix building under -fno-common (diff)
downloadgentoo-c9843a298647c9fd076a4fb54320cdf8a47466ae.tar.gz
gentoo-c9843a298647c9fd076a4fb54320cdf8a47466ae.tar.bz2
gentoo-c9843a298647c9fd076a4fb54320cdf8a47466ae.zip
media-libs/codec2: Fix building under -fno-common
Closes: https://bugs.gentoo.org/707668 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/codec2')
-rw-r--r--media-libs/codec2/codec2-0.8.1.ebuild5
-rw-r--r--media-libs/codec2/files/codec2-0.8.1-fno-common.patch11
2 files changed, 15 insertions, 1 deletions
diff --git a/media-libs/codec2/codec2-0.8.1.ebuild b/media-libs/codec2/codec2-0.8.1.ebuild
index 50150b2cb65a..8dbf9acea974 100644
--- a/media-libs/codec2/codec2-0.8.1.ebuild
+++ b/media-libs/codec2/codec2-0.8.1.ebuild
@@ -15,7 +15,10 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
IUSE="examples"
-PATCHES=( "${FILESDIR}/${P}-unused-deps.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-unused-deps.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
multilib_src_configure() {
local mycmakeargs=( -DUNITTEST=OFF )
diff --git a/media-libs/codec2/files/codec2-0.8.1-fno-common.patch b/media-libs/codec2/files/codec2-0.8.1-fno-common.patch
new file mode 100644
index 000000000000..d5818a01f5c5
--- /dev/null
+++ b/media-libs/codec2/files/codec2-0.8.1-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/codec2_ofdm.h
++++ b/src/codec2_ofdm.h
+@@ -51,7 +51,7 @@
+ struct OFDM;
+
+ /* Default configuration for '700D' mode */
+-const struct OFDM_CONFIG * OFDM_CONFIG_700D;
++extern const struct OFDM_CONFIG * OFDM_CONFIG_700D;
+
+ /* create and destroy modem states */
+