summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-03-20 03:26:05 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-20 04:09:59 +0100
commit72a53ebb693b0a6e6ef8493fa70a2c3b141c4669 (patch)
tree7032727ea88fa6474309f3b8ac089374e30a85de /media-libs/dav1d/dav1d-0.2.0-r1.ebuild
parentmedia-libs/dav1d: x86 keyworded (diff)
downloadgentoo-72a53ebb693b0a6e6ef8493fa70a2c3b141c4669.tar.gz
gentoo-72a53ebb693b0a6e6ef8493fa70a2c3b141c4669.tar.bz2
gentoo-72a53ebb693b0a6e6ef8493fa70a2c3b141c4669.zip
media-libs/dav1d: expose subslot
Closes: https://bugs.gentoo.org/679572 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/dav1d/dav1d-0.2.0-r1.ebuild')
-rw-r--r--media-libs/dav1d/dav1d-0.2.0-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/dav1d/dav1d-0.2.0-r1.ebuild b/media-libs/dav1d/dav1d-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..361df4a791a4
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.2.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+inherit ${SCM} meson ninja-utils multilib-minimal
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0/1"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.13"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ build_asm=false
+ else
+ build_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D build_asm=$build_asm
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}