summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-02-21 13:41:41 -0500
committerMike Frysinger <vapier@gentoo.org>2016-02-21 14:03:43 -0500
commit42b7752bd599c757d65ead7914a98d9f69668ffd (patch)
tree97d8bd4343001b3e72c5db7dfcb8349c5bfaefc5 /media-libs/elementary/elementary-9999.ebuild
parentprofiles/arch: mask elementary[javascript] pending testing #575322 (diff)
downloadgentoo-42b7752bd599c757d65ead7914a98d9f69668ffd.tar.gz
gentoo-42b7752bd599c757d65ead7914a98d9f69668ffd.tar.bz2
gentoo-42b7752bd599c757d65ead7914a98d9f69668ffd.zip
media-libs/elementary: version bump to 1.17.0 #573784
Diffstat (limited to 'media-libs/elementary/elementary-9999.ebuild')
-rw-r--r--media-libs/elementary/elementary-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-libs/elementary/elementary-9999.ebuild b/media-libs/elementary/elementary-9999.ebuild
index 7cef5b066732..a719301834b2 100644
--- a/media-libs/elementary/elementary-9999.ebuild
+++ b/media-libs/elementary/elementary-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,9 +20,10 @@ DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices"
HOMEPAGE="https://trac.enlightenment.org/e/wiki/Elementary"
LICENSE="LGPL-2.1"
-IUSE="debug examples fbcon quicklaunch sdl wayland X static-libs"
+IUSE="debug examples fbcon javascript quicklaunch sdl wayland X static-libs"
-DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]"
+DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]
+ javascript? ( net-libs/nodejs )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
@@ -41,8 +42,9 @@ src_configure() {
#$(use_enable examples build-examples)
$(use_enable examples install-examples)
$(use_enable fbcon ecore-fb)
+ $(use_enable javascript js-bindings)
$(use_enable sdl ecore-sdl)
- $(use_enable wayland ecore-wayland)
+ $(use_enable wayland ecore-wl2)
$(use_enable X ecore-x)
$(use_enable quicklaunch quick-launch)
)