summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/ethumb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/ethumb')
-rw-r--r--media-libs/ethumb/Manifest2
-rw-r--r--media-libs/ethumb/ethumb-1.7.8.ebuild33
-rw-r--r--media-libs/ethumb/ethumb-1.7.9.ebuild33
-rw-r--r--media-libs/ethumb/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/ethumb/Manifest b/media-libs/ethumb/Manifest
new file mode 100644
index 000000000000..af5016ffb70e
--- /dev/null
+++ b/media-libs/ethumb/Manifest
@@ -0,0 +1,2 @@
+DIST ethumb-1.7.8.tar.bz2 401664 SHA256 c1e6f2bf5117a1b6b9bac8c9ccd72b4b8ade6c03ca1cb77f2ff51538ec5f1ba7 SHA512 a04270852d49cf8f9127fcdc4bd5994374905f5514954d0d18ee731bfd5269a0a511f0741ff046a95d028e3b031f7ab5806262d29ee9acf50b957d2c7003822b WHIRLPOOL a2f7936c712d51ed35bc4ec0035bc3eda6f8c9acf05d3500a8a231f99604f7331200a9f17bc2fa45d640096b71d7dd8adb99769402cfc770ed2eb31438064580
+DIST ethumb-1.7.9.tar.bz2 401952 SHA256 9bbf89f82c5c74a70ffd03a4942d0c28a019c3763d1c0b8c14301036981312af SHA512 2ff6149104e1d1b55382cfa156b9fa6415be78f55b73e50c49211fb0714519611b04b6142e38a28ffe8209899d3fbd0981de12e983486511a61d9d66ef8186b5 WHIRLPOOL 72e7fad74a7c688fc4b8a76d5f0e4ab8987c62ea3c64ea45d68c2a165b44b6b443375907c7a856e97f6aa4c60164f78b9ce04b070032bf3f28fc89618c7cd7a7
diff --git a/media-libs/ethumb/ethumb-1.7.8.ebuild b/media-libs/ethumb/ethumb-1.7.8.ebuild
new file mode 100644
index 000000000000..a4ef6d93c6b4
--- /dev/null
+++ b/media-libs/ethumb/ethumb-1.7.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment thumbnailing library (meant to replace epsilon)"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Ethumb"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus emotion static-libs"
+
+DEPEND=">=dev-libs/eina-1.7.8
+ >=dev-libs/ecore-1.7.8
+ >=media-libs/edje-1.7.8
+ >=media-libs/evas-1.7.8
+ media-libs/libexif
+ dbus? ( >=dev-libs/e_dbus-1.7.8 )
+ emotion? ( >=media-libs/emotion-1.7.8 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ E_ECONF+=(
+ $(use_enable dbus ethumbd)
+ $(use_enable emotion)
+ --disable-epdf
+ )
+ enlightenment_src_configure
+}
diff --git a/media-libs/ethumb/ethumb-1.7.9.ebuild b/media-libs/ethumb/ethumb-1.7.9.ebuild
new file mode 100644
index 000000000000..1b40964419c8
--- /dev/null
+++ b/media-libs/ethumb/ethumb-1.7.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment thumbnailing library (meant to replace epsilon)"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Ethumb"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus emotion static-libs"
+
+DEPEND=">=dev-libs/eina-1.7.9
+ >=dev-libs/ecore-1.7.9
+ >=media-libs/edje-1.7.9
+ >=media-libs/evas-1.7.9
+ media-libs/libexif
+ dbus? ( >=dev-libs/e_dbus-1.7.9 )
+ emotion? ( >=media-libs/emotion-1.7.9 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ E_ECONF+=(
+ $(use_enable dbus ethumbd)
+ $(use_enable emotion)
+ --disable-epdf
+ )
+ enlightenment_src_configure
+}
diff --git a/media-libs/ethumb/metadata.xml b/media-libs/ethumb/metadata.xml
new file mode 100644
index 000000000000..031abb11daaf
--- /dev/null
+++ b/media-libs/ethumb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>enlightenment</herd>
+ <use>
+ <flag name='emotion'>Add support for <pkg>media-libs/emotion</pkg></flag>
+ </use>
+</pkgmetadata>