summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-04-16 20:20:30 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-04-16 20:24:59 +0200
commit34b7e89302085c215bd19f307c4ea914287d3d9d (patch)
tree8418c09d8a4a5a85fd0701740c23eca2a883d615 /media-libs/exempi
parentx11-misc/easystroke: Add subslot operator to dev-libs/boost (diff)
downloadgentoo-34b7e89302085c215bd19f307c4ea914287d3d9d.tar.gz
gentoo-34b7e89302085c215bd19f307c4ea914287d3d9d.tar.bz2
gentoo-34b7e89302085c215bd19f307c4ea914287d3d9d.zip
media-libs/exempi: version bump 2.2.1 → 2.4.2
Bump to EAPI=6. Add missing dependency on autoconf-archive. Switch eutils to ltprune. Enable unittests. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-libs/exempi')
-rw-r--r--media-libs/exempi/Manifest1
-rw-r--r--media-libs/exempi/exempi-2.4.2.ebuild52
-rw-r--r--media-libs/exempi/files/exempi-2.4.2-iconv.patch41
3 files changed, 94 insertions, 0 deletions
diff --git a/media-libs/exempi/Manifest b/media-libs/exempi/Manifest
index 97322306fcb6..5fa206457afa 100644
--- a/media-libs/exempi/Manifest
+++ b/media-libs/exempi/Manifest
@@ -1 +1,2 @@
DIST exempi-2.2.1.tar.gz 3566843 SHA256 a99e1569047988200e4935cf4395667341a5bd8d6067847a08df4304546cc362 SHA512 f4b97ec7af89924755a0695464bad5081de6a5d6a6f28c06984c051d677f8771c39df12951761ecd28d6ff520ddec4e21179dcba8b58f0ef649bbdad1a53aa9c WHIRLPOOL 622d23cb519f2dda988b7d13dd26be55dd207bfe8ec2f2c0b8b568974571780b51b5284d871a310e461041f1054265efb199cf5c21fcf6eee6619cb85dc335e9
+DIST exempi-2.4.2.tar.gz 3911796 SHA256 2016738b16c371179f745a556dc8ccc95ba2323e933fa1b3f4cbbd469516e343 SHA512 47d0737a95dbd31c3c39ef9a9a8c00e87135c2eb909bea1d89fa8df31c0e73dadd7e9f9f0e6445d3b17457396e0c1381b93f5751494e1061822df47f7099b568 WHIRLPOOL 50bff108827ea794aacb1becee05b0864a694b6744be4471d9e16bccd5143d3957f8d5e41cd946df1e453a9c1abfeaa11cf170ddbd4db6e339b85d7e7bac1930
diff --git a/media-libs/exempi/exempi-2.4.2.ebuild b/media-libs/exempi/exempi-2.4.2.ebuild
new file mode 100644
index 000000000000..cbc59b14fc96
--- /dev/null
+++ b/media-libs/exempi/exempi-2.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools ltprune
+
+DESCRIPTION="Exempi is a port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
+SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples static-libs test"
+
+RDEPEND="
+ >=dev-libs/expat-2:=
+ virtual/libiconv
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+ test? ( >=dev-libs/boost-1.48 )
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-2.4.2-iconv.patch
+ cp /usr/share/gettext/config.rpath . || die
+ eautoreconf
+}
+
+src_configure() {
+ # Valgrind detection is "disabled" due to bug #295875
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unittest) \
+ VALGRIND=""
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm -f samples/{,source,testfiles}/Makefile*
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/*
+ fi
+}
diff --git a/media-libs/exempi/files/exempi-2.4.2-iconv.patch b/media-libs/exempi/files/exempi-2.4.2-iconv.patch
new file mode 100644
index 000000000000..9f9fc42e5bf9
--- /dev/null
+++ b/media-libs/exempi/files/exempi-2.4.2-iconv.patch
@@ -0,0 +1,41 @@
+From a2b822c85c52c96b04192a4923c9edbf9d144343 Mon Sep 17 00:00:00 2001
+From: Samuli Suominen <ssuominen@gentoo.org>
+Date: Sun, 16 Apr 2017 20:11:57 +0200
+Subject: [PATCH] Fix build on systems not using glibc's libiconv
+
+Fixes: https://bugs.gentoo.org/show_bug.cgi?id=242812
+Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
+
+---
+ XMPFiles/source/Makefile.am | 3 ++-
+ configure.ac | 2 ++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/XMPFiles/source/Makefile.am b/XMPFiles/source/Makefile.am
+index 6d1a1d3..d1020d0 100644
+--- a/XMPFiles/source/Makefile.am
++++ b/XMPFiles/source/Makefile.am
+@@ -53,5 +53,6 @@ libXMPFiles_la_SOURCES = WXMPFiles.cpp XMPFiles.cpp \
+ libXMPFiles_la_LIBADD = ./FileHandlers/libxmpfilehandlers.la \
+ ./FormatSupport/libformatsupport.la \
+ ./PluginHandler/libpluginhandler.la \
+- ./NativeMetadataSupport/libnativemetadata.la
++ ./NativeMetadataSupport/libnativemetadata.la \
++ @LTLIBICONV@
+ #libXMPFiles_la_LDFLAGS = -version-info @LIBXMPCORE_VERSION_INFO@
+diff --git a/configure.ac b/configure.ac
+index a4ee14f..e1033c1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -115,6 +115,8 @@ AC_CHECK_HEADER(iconv.h, ,
+ AC_CHECK_HEADER(zlib.h, ,
+ AC_MSG_ERROR([zlib headers missing]))
+
++AM_ICONV_LINK
++
+ dnl Blatently copied from iconv.m4 to remove the crack about libtool
+ dnl But check for constness of the iconv parameters.
+ AC_MSG_CHECKING([for iconv declaration])
+--
+2.12.2
+