summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-23 16:25:04 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-23 16:25:04 +0100
commit0597ad045c450eb468c4500d9ddb05584de70c3d (patch)
treee13ccb69b510510b289b42b583dc9bdecedc8cde /media-libs/faac
parentmedia-libs/libid3tag: Port to EAPI 7 (diff)
downloadgentoo-0597ad045c450eb468c4500d9ddb05584de70c3d.tar.gz
gentoo-0597ad045c450eb468c4500d9ddb05584de70c3d.tar.bz2
gentoo-0597ad045c450eb468c4500d9ddb05584de70c3d.zip
media-libs/faac: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/faac')
-rw-r--r--media-libs/faac/faac-1.29.9.2.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/media-libs/faac/faac-1.29.9.2.ebuild b/media-libs/faac/faac-1.29.9.2.ebuild
index 58776bbdaad1..8b790a669fc9 100644
--- a/media-libs/faac/faac-1.29.9.2.ebuild
+++ b/media-libs/faac/faac-1.29.9.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools epunt-cxx multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="Free MPEG-4 audio codecs by AudioCoding.com"
HOMEPAGE="https://www.audiocoding.com"
@@ -12,34 +12,25 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1 MPEG-4"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="static-libs"
-
-DEPEND="${RDEPEND}"
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
src_prepare() {
default
-
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466984
-
eautoreconf
- epunt_cxx
}
multilib_src_configure() {
- local myconf=(
- $(use_enable static-libs static)
- )
+ ECONF_SOURCE="${S}" econf --disable-static
- ECONF_SOURCE="${S}" econf ${myconf[@]}
-
- # do not build the frontend for non default abis
- if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
+ # do not build the frontend for non-native abis
+ if ! multilib_is_native_abi; then
sed -i -e 's/frontend//' Makefile || die
fi
}
-multilib_src_install() {
- emake DESTDIR="${D}" install
+multilib_src_install_all() {
+ einstalldocs
+
+ # no static archives
find "${D}" -name '*.la' -delete || die
}