summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-29 14:10:18 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-29 14:31:10 -0700
commitcb4e0fff8ee47621a4cbbb3f905a3ff63ae316c0 (patch)
tree81d20dd24f6bd3e42fa2cc8123fefbb7b5d95e25 /media-libs/freeglut/freeglut-3.2.1.ebuild
parentprofiles: drop chromium mask (diff)
downloadgentoo-cb4e0fff8ee47621a4cbbb3f905a3ff63ae316c0.tar.gz
gentoo-cb4e0fff8ee47621a4cbbb3f905a3ff63ae316c0.tar.bz2
gentoo-cb4e0fff8ee47621a4cbbb3f905a3ff63ae316c0.zip
media-libs/freeglut: Version bump to 3.2.1
Closes: https://bugs.gentoo.org/694774 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/freeglut/freeglut-3.2.1.ebuild')
-rw-r--r--media-libs/freeglut/freeglut-3.2.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/freeglut/freeglut-3.2.1.ebuild b/media-libs/freeglut/freeglut-3.2.1.ebuild
new file mode 100644
index 000000000000..a696fe8a8fdf
--- /dev/null
+++ b/media-libs/freeglut/freeglut-3.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="A free OpenGL utility toolkit, the open-sourced alternative to the GLUT library"
+HOMEPAGE="http://freeglut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug static-libs"
+
+# enabling GLES support seems to cause build failures
+RDEPEND=">=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]"
+# gles? ( media-libs/mesa[egl,gles1,gles2,${MULTILIB_USEDEP}] )
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( doc/. )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DFREEGLUT_GLES=OFF"
+ "-DFREEGLUT_BUILD_DEMOS=OFF"
+ "-DFREEGLUT_BUILD_STATIC_LIBS=$(usex static-libs ON OFF)"
+ )
+# $(cmake-utils_use gles FREEGLUT_GLES)
+ cmake-multilib_src_configure
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+ cp "${D}"/usr/$(get_libdir)/pkgconfig/{,free}glut.pc
+}