summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-09-01 22:42:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-09-01 22:54:29 +0200
commit102baa282bb124e37febc17d24e9b84767272fc4 (patch)
treedf2af72921da3e605f77a174642b8aa4ef6c0f04 /media-libs/gd
parentsys-boot/grub: update metadata to list me as the maintainer of grub-legacy (diff)
downloadgentoo-102baa282bb124e37febc17d24e9b84767272fc4.tar.gz
gentoo-102baa282bb124e37febc17d24e9b84767272fc4.tar.bz2
gentoo-102baa282bb124e37febc17d24e9b84767272fc4.zip
media-libs/gd: Bump to version 2.2.5
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-libs/gd')
-rw-r--r--media-libs/gd/Manifest1
-rw-r--r--media-libs/gd/gd-2.2.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/gd/Manifest b/media-libs/gd/Manifest
index cc46b94908bf..4cc99d4511f9 100644
--- a/media-libs/gd/Manifest
+++ b/media-libs/gd/Manifest
@@ -1 +1,2 @@
DIST libgd-2.2.4.tar.xz 2478528 SHA256 137f13a7eb93ce72e32ccd7cebdab6874f8cf7ddf31d3a455a68e016ecd9e4e6 SHA512 07903f322c4f6ab392508b0f60c38ca133699111ea92995dc6cd9379210d598bcb24a46c19657884d9e252f8663d0ee8c89c600e3a382a5ae598198c190f39b5 WHIRLPOOL eb00e684e8db02e649b3e6e2e76e7eff1e7aaa08995d78cef429b2b2053798aa1a44cd5b5eed5d3bc042394e72096d90ccc238ab3759e11fd543c80b697d0d91
+DIST libgd-2.2.5.tar.xz 2594092 SHA256 8c302ccbf467faec732f0741a859eef4ecae22fea2d2ab87467be940842bde51 SHA512 e4598e17a277a75e02255402182cab139cb3f2cffcd68ec05cc10bbeaf6bc7aa39162c3445cd4a7efc1a26b72b9152bbedb187351e3ed099ea51767319997a6b WHIRLPOOL 0ca5f05ebf03ec38caa028862379c3ad78da0a28b933a150b7635135807aa0a7d6bb85f4e9c206dd0ba0d3ce8ef64cc1ba1a3d929f0aad737a6b48d4453e33ef
diff --git a/media-libs/gd/gd-2.2.5.ebuild b/media-libs/gd/gd-2.2.5.ebuild
new file mode 100644
index 000000000000..3db0e012734d
--- /dev/null
+++ b/media-libs/gd/gd-2.2.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit libtool ltprune multilib-minimal
+
+DESCRIPTION="A graphics library for fast image creation"
+HOMEPAGE="http://libgd.org/ http://www.boutell.com/gd/"
+SRC_URI="https://github.com/libgd/libgd/releases/download/${P}/lib${P}.tar.xz"
+
+LICENSE="gd IJG HPND BSD"
+SLOT="2/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="fontconfig jpeg png static-libs tiff truetype webp xpm zlib"
+
+# fontconfig has prefixed font paths, details see bug #518970
+REQUIRED_USE="prefix? ( fontconfig )"
+
+RDEPEND="fontconfig? ( >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
+ tiff? ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+ truetype? ( >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}] )
+ webp? ( media-libs/libwebp:=[${MULTILIB_USEDEP}] )
+ xpm? ( >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}] >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}/lib${P}"
+
+src_prepare() {
+ default
+ elibtoolize # for shared library on Solaris
+}
+
+multilib_src_configure() {
+ # we aren't actually {en,dis}abling X here ... the configure
+ # script uses it just to add explicit -I/-L paths which we
+ # don't care about on Gentoo systems.
+ local myeconfargs=(
+ --disable-werror
+ --without-x
+ --without-liq
+ $(use_enable static-libs static)
+ $(use_with fontconfig)
+ $(use_with png)
+ $(use_with tiff)
+ $(use_with truetype freetype)
+ $(use_with jpeg)
+ $(use_with webp)
+ $(use_with xpm)
+ $(use_with zlib)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+ prune_libtool_files
+}