summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-03-30 00:43:28 +0200
committerSebastian Pipping <sping@gentoo.org>2017-03-30 00:44:43 +0200
commitf485f2efa7e7c461da643f59b98295d1f02b916f (patch)
tree146af6eec9596ae4b65fd6cbff6b695c4e7f6840 /media-libs/gexiv2
parentdev-java/mina-core: clean up old. (diff)
downloadgentoo-f485f2efa7e7c461da643f59b98295d1f02b916f.tar.gz
gentoo-f485f2efa7e7c461da643f59b98295d1f02b916f.tar.bz2
gentoo-f485f2efa7e7c461da643f59b98295d1f02b916f.zip
media-libs/gexiv2: Fix compilation (bug #613778)
Thanks to Markus Moll for the patch! Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/files/gexiv2-0.10.5-stdexcept.patch11
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.5-r1.ebuild60
2 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/gexiv2/files/gexiv2-0.10.5-stdexcept.patch b/media-libs/gexiv2/files/gexiv2-0.10.5-stdexcept.patch
new file mode 100644
index 000000000000..dc9c5825b90e
--- /dev/null
+++ b/media-libs/gexiv2/files/gexiv2-0.10.5-stdexcept.patch
@@ -0,0 +1,11 @@
+diff -Naur gexiv2-0.10.5/gexiv2/gexiv2-metadata-gps.cpp gexiv2-0.10.5b/gexiv2/gexiv2-metadata-gps.cpp
+--- gexiv2-0.10.5/gexiv2/gexiv2-metadata-gps.cpp 2017-03-19 18:00:55.000000000 +0100
++++ gexiv2-0.10.5b/gexiv2/gexiv2-metadata-gps.cpp 2017-03-26 09:45:44.638692802 +0200
+@@ -12,6 +12,7 @@
+ #include "gexiv2-metadata-private.h"
+ #include <string>
+ #include <cmath>
++#include <stdexcept>
+ #include <stdio.h>
+ #include <glib-object.h>
+ #include <exiv2/exif.hpp>
diff --git a/media-libs/gexiv2/gexiv2-0.10.5-r1.ebuild b/media-libs/gexiv2/gexiv2-0.10.5-r1.ebuild
new file mode 100644
index 000000000000..8ba9a36dfbaa
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.10.5-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools eutils multilib python-r1 toolchain-funcs versionator xdg-utils
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="introspection python static-libs test"
+
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ test? ( python )
+"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.1:2
+ >=media-gfx/exiv2-0.21:0=
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.5-stdexcept.patch
+)
+
+src_prepare() {
+ xdg_environment_reset
+ tc-export CXX
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+
+ use static-libs || prune_libtool_files --modules
+}