summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-03-08 09:58:45 +0100
committerTupone Alfredo <tupone@gentoo.org>2019-03-08 09:58:45 +0100
commit86f0a723163670d49a8f9f0da6b2060094962061 (patch)
tree7b52fec23f49f28f322b6b516ec4afef77d29b33 /media-libs/glm
parentnet-proxy/squid: replace echo with printf (avoid bashism v2) (diff)
downloadgentoo-86f0a723163670d49a8f9f0da6b2060094962061.tar.gz
gentoo-86f0a723163670d49a8f9f0da6b2060094962061.tar.bz2
gentoo-86f0a723163670d49a8f9f0da6b2060094962061.zip
media-libs/glm: Enabled all tests. Increase the error tolerance
Closes: https://bugs.gentoo.org/669638 Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-libs/glm')
-rw-r--r--media-libs/glm/files/glm-0.9.9.2-avx.patch42
1 files changed, 33 insertions, 9 deletions
diff --git a/media-libs/glm/files/glm-0.9.9.2-avx.patch b/media-libs/glm/files/glm-0.9.9.2-avx.patch
index 87d8c5bd598a..7ac91f490a13 100644
--- a/media-libs/glm/files/glm-0.9.9.2-avx.patch
+++ b/media-libs/glm/files/glm-0.9.9.2-avx.patch
@@ -19,12 +19,36 @@
add_compile_options(-Wno-long-long)
elseif(CMAKE_CXX_COMPILER_ID MATCHES "Intel")
---- a/test/perf/CMakeLists.txt 2019-03-06 20:32:35.172976526 +0100
-+++ b/test/perf/CMakeLists.txt 2019-03-06 20:33:04.138486121 +0100
-@@ -1,6 +1,4 @@
--glmCreateTestGTC(perf_matrix_div)
- glmCreateTestGTC(perf_matrix_inverse)
- glmCreateTestGTC(perf_matrix_mul)
--glmCreateTestGTC(perf_matrix_mul_vector)
- glmCreateTestGTC(perf_matrix_transpose)
- glmCreateTestGTC(perf_vector_mul_matrix)
+--- a/test/perf/perf_matrix_div.cpp 2019-03-08 09:42:30.180305872 +0100
++++ b/test/perf/perf_matrix_div.cpp 2019-03-08 09:42:40.381140911 +0100
+@@ -109,7 +109,7 @@
+ {
+ packedMatType const A = SISD[i];
+ packedMatType const B = SIMD[i];
+- Error += glm::all(glm::equal(A, B, static_cast<T>(0.001))) ? 0 : 1;
++ Error += glm::all(glm::equal(A, B, static_cast<T>(0.002))) ? 0 : 1;
+ assert(!Error);
+ }
+
+--- a/test/perf/perf_matrix_mul.cpp 2019-03-08 09:51:09.411923180 +0100
++++ b/test/perf/perf_matrix_mul.cpp 2019-03-08 09:51:53.465219910 +0100
+@@ -111,7 +111,7 @@
+ {
+ packedMatType const A = SISD[i];
+ packedMatType const B = SIMD[i];
+- Error += glm::all(glm::equal(A, B, static_cast<T>(0.001))) ? 0 : 1;
++ Error += glm::all(glm::equal(A, B, static_cast<T>(0.01))) ? 0 : 1;
+ }
+
+ return Error;
+--- a/test/perf/perf_matrix_mul_vector.cpp 2019-03-08 09:43:10.450654282 +0100
++++ b/test/perf/perf_matrix_mul_vector.cpp 2019-03-08 09:50:09.685875081 +0100
+@@ -111,7 +111,7 @@
+ {
+ packedVecType const A = SISD[i];
+ packedVecType const B = SIMD[i];
+- Error += glm::all(glm::equal(A, B, static_cast<T>(0.001))) ? 0 : 1;
++ Error += glm::all(glm::equal(A, B, static_cast<T>(0.01))) ? 0 : 1;
+ }
+
+ return Error;