summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-03-06 20:45:56 +0100
committerTupone Alfredo <tupone@gentoo.org>2019-03-06 20:46:29 +0100
commitc5c19f7820c56475a0b0b3ee84f913f235949a87 (patch)
tree80137bc71a07bb022df600ce7f0c1fe0c0d3144f /media-libs/glm
parentnet-misc/openssh: arm64 stable (bug #675522) (diff)
downloadgentoo-c5c19f7820c56475a0b0b3ee84f913f235949a87.tar.gz
gentoo-c5c19f7820c56475a0b0b3ee84f913f235949a87.tar.bz2
gentoo-c5c19f7820c56475a0b0b3ee84f913f235949a87.zip
media-libs/glm: Disable avx. Remove failing test.
Closes: https://bugs.gentoo.org/669638 Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-libs/glm')
-rw-r--r--media-libs/glm/files/glm-0.9.9.2-avx.patch30
-rw-r--r--media-libs/glm/glm-0.9.9.2.ebuild4
2 files changed, 33 insertions, 1 deletions
diff --git a/media-libs/glm/files/glm-0.9.9.2-avx.patch b/media-libs/glm/files/glm-0.9.9.2-avx.patch
new file mode 100644
index 000000000000..87d8c5bd598a
--- /dev/null
+++ b/media-libs/glm/files/glm-0.9.9.2-avx.patch
@@ -0,0 +1,30 @@
+--- a/glm/simd/platform.h 2019-03-06 18:57:53.309630574 +0100
++++ b/glm/simd/platform.h 2019-03-06 18:58:30.796988006 +0100
+@@ -233,7 +233,7 @@
+ #define GLM_ARCH_SSSE3_BIT (0x00000010)
+ #define GLM_ARCH_SSE41_BIT (0x00000020)
+ #define GLM_ARCH_SSE42_BIT (0x00000040)
+-#define GLM_ARCH_AVX_BIT (0x00000080)
++#define GLM_ARCH_AVX_BIT (0x00000000)
+ #define GLM_ARCH_AVX2_BIT (0x00000100)
+
+ #define GLM_ARCH_UNKNOWN (0)
+--- a/CMakeLists.txt 2019-03-06 19:27:14.052353176 +0100
++++ b/CMakeLists.txt 2019-03-06 19:27:05.161503895 +0100
+@@ -203,7 +203,6 @@
+ message("GLM: GCC - ${CMAKE_CXX_COMPILER_ID} compiler")
+ endif()
+
+- add_compile_options(-O2)
+ add_compile_options(-Wno-long-long)
+
+ elseif(CMAKE_CXX_COMPILER_ID MATCHES "Intel")
+--- a/test/perf/CMakeLists.txt 2019-03-06 20:32:35.172976526 +0100
++++ b/test/perf/CMakeLists.txt 2019-03-06 20:33:04.138486121 +0100
+@@ -1,6 +1,4 @@
+-glmCreateTestGTC(perf_matrix_div)
+ glmCreateTestGTC(perf_matrix_inverse)
+ glmCreateTestGTC(perf_matrix_mul)
+-glmCreateTestGTC(perf_matrix_mul_vector)
+ glmCreateTestGTC(perf_matrix_transpose)
+ glmCreateTestGTC(perf_vector_mul_matrix)
diff --git a/media-libs/glm/glm-0.9.9.2.ebuild b/media-libs/glm/glm-0.9.9.2.ebuild
index 8f93505e3279..cb748d8c62e1 100644
--- a/media-libs/glm/glm-0.9.9.2.ebuild
+++ b/media-libs/glm/glm-0.9.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,6 +16,8 @@ IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86
RDEPEND="virtual/opengl"
+PATCHES=( "${FILESDIR}"/${P}-avx.patch )
+
src_configure() {
if use test; then
local mycmakeargs=(